summaryrefslogtreecommitdiffstats
path: root/tools/linux/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tools/linux/Makefile.am')
-rw-r--r--tools/linux/Makefile.am23
1 files changed, 22 insertions, 1 deletions
diff --git a/tools/linux/Makefile.am b/tools/linux/Makefile.am
index 5091efe..3283b5e 100644
--- a/tools/linux/Makefile.am
+++ b/tools/linux/Makefile.am
@@ -9,6 +9,7 @@ SUBDIRS = \
INCLUDES = \
-I. \
-I$(srcdir) \
+ -I$(top_srcdir)/src \
$(CONSOLE_KIT_CFLAGS) \
$(DISABLE_DEPRECATED_CFLAGS) \
-DPREFIX=\""$(prefix)"\" \
@@ -22,7 +23,27 @@ INCLUDES = \
$(TOOLS_CFLAGS) \
$(NULL)
-libexec_PROGRAMS = \
+libexec_PROGRAMS = \
+ ck-collect-session-info \
+ ck-get-x11-server-pid \
+ $(NULL)
+
+ck_collect_session_info_SOURCES = \
+ $(top_srcdir)/src/proc.h \
+ $(top_srcdir)/src/proc-linux.c \
+ ck-collect-session-info.c \
+ $(NULL)
+
+ck_collect_session_info_LDADD = \
+ $(TOOLS_LIBS) \
+ $(NULL)
+
+ck_get_x11_server_pid_SOURCES = \
+ ck-get-x11-server-pid.c \
+ $(NULL)
+
+ck_get_x11_server_pid_LDADD = \
+ $(TOOLS_LIBS) \
$(NULL)
EXTRA_DIST = \