summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2005-11-19 12:33:00 +0000
committerLennart Poettering <lennart@poettering.net>2005-11-19 12:33:00 +0000
commit1b1e2692e498d7bab5183c344887f83c0a94e4bb (patch)
tree69fe46fc4ddef77442c44d34c270acc4a1751ba7 /Makefile.am
parent1bdaeafd441242366d6775f1ae4c38647e6f83ee (diff)
build pkg-config for compat layers only when the compat layers are enabled
git-svn-id: file:///home/lennart/svn/public/avahi/trunk@1012 941a03a8-eaeb-0310-b9a0-b1bbd8fe43fe
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am28
1 files changed, 23 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index f2e3b39..5690c5b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -105,21 +105,37 @@ CLEANFILES = avahi-core.pc
if HAVE_DBUS
-pkgconfig_DATA += avahi-client.pc avahi-compat-libdns_sd.pc avahi-compat-howl.pc
+pkgconfig_DATA += avahi-client.pc
avahi-client.pc: avahi-client.pc.in
sed -e 's,@prefix\@,$(prefix),g' \
-e 's,@PACKAGE_VERSION\@,$(PACKAGE_VERSION),g' $< > $@
-avahi-compat-libdns_sd.pc: avahi-compat-libdns_sd.pc.in
- sed -e 's,@prefix\@,$(prefix),g' \
- -e 's,@PACKAGE_VERSION\@,$(PACKAGE_VERSION),g' $< > $@
+CLEANFILES += avahi-client.pc
+
+if ENABLE_COMPAT_HOWL
+
+pkgconfig_DATA += avahi-compat-howl.pc
avahi-compat-howl.pc: avahi-compat-howl.pc.in
sed -e 's,@prefix\@,$(prefix),g' \
-e 's,@HOWL_COMPAT_VERSION\@,$(HOWL_COMPAT_VERSION),g' $< > $@
-CLEANFILES += avahi-client.pc avahi-compat-libdns_sd.pc avahi-compat-howl.pc
+CLEANFILES += avahi-compat-howl.pc
+
+endif
+
+if ENABLE_COMPAT_LIBDNS_SD
+
+pkgconfig_DATA += avahi-compat-libdns_sd.pc
+
+avahi-compat-libdns_sd.pc: avahi-compat-libdns_sd.pc.in
+ sed -e 's,@prefix\@,$(prefix),g' \
+ -e 's,@PACKAGE_VERSION\@,$(PACKAGE_VERSION),g' $< > $@
+
+CLEANFILES += avahi-compat-libdns_sd.pc
+
+endif
endif
@@ -160,6 +176,7 @@ CLEANFILES += avahi-qt4.pc
endif
if HAVE_MONO
+if HAVE_DBUS
pkgconfig_DATA += avahi-sharp.pc
@@ -171,6 +188,7 @@ avahi-sharp.pc: avahi-sharp.pc.in
CLEANFILES += avahi-sharp.pc
endif
+endif
MOSTLYCLEANFILES = $(DX_CLEANFILES)