summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2010-06-25 05:29:23 +0200
committerLennart Poettering <lennart@poettering.net>2010-06-25 05:29:23 +0200
commit767bac373b93988410269f170a1dcbd45bc97777 (patch)
tree1cca697c1fea46acff7c8595a759a475c6491155 /Makefile.am
parent5e401ee6a8f1c0d0a84e9e239c47f50607e4c093 (diff)
gtk: build for both gtk2 and gtk3
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 02e3a9c..15a6cd8 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -48,6 +48,7 @@ EXTRA_DIST = \
avahi-compat-libdns_sd.pc.in \
avahi-compat-howl.pc.in \
avahi-ui.pc.in \
+ avahi-ui-gtk3.pc.in \
doxygen_to_devhelp.xsl
SUBDIRS = \
@@ -196,6 +197,13 @@ CLEANFILES += avahi-ui.pc
endif
endif
+if HAVE_GTK3
+if HAVE_DBUS
+pkgconfig_DATA += avahi-ui-gtk3.pc
+CLEANFILES += avahi-ui-gtk3.pc
+endif
+endif
+
if HAVE_QT3
pkgconfig_DATA += avahi-qt3.pc
CLEANFILES += avahi-qt3.pc