summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2005-10-15 15:55:57 +0000
committerLennart Poettering <lennart@poettering.net>2005-10-15 15:55:57 +0000
commit91dd7be01d4f3571da4471186700d4a7d27c1ca8 (patch)
treef0868461d98451534876bf8002d168a42c7be274 /Makefile.am
parent76bbc91a5d2f151430bf7ecc3328e0147e60c346 (diff)
* add pkg-config file for compat-howl
* fix pkg-config file generation for compat-libdns_sd git-svn-id: file:///home/lennart/svn/public/avahi/trunk@773 941a03a8-eaeb-0310-b9a0-b1bbd8fe43fe
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am18
1 files changed, 11 insertions, 7 deletions
diff --git a/Makefile.am b/Makefile.am
index 12465c5..f00531d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -95,27 +95,31 @@ DX_EXAMPLE_PATH = $(srcdir)/examples
DX_EXAMPLE_PATTERNS = *.c
pkgconfigdir = $(libdir)/pkgconfig
-pkgconfig_DATA = avahi-core.pc avahi-compat-libdns_sd.pc
+pkgconfig_DATA = avahi-core.pc
avahi-core.pc: avahi-core.pc.in
sed -e 's,@prefix\@,$(prefix),g' \
-e 's,@PACKAGE_VERSION\@,$(PACKAGE_VERSION),g' $< > $@
-avahi-compat-libdns_sd.pc: avahi-compat-libdns_sd.pc.in
- sed -e 's,@prefix\@,$(prefix),g' \
- -e 's,@PACKAGE_VERSION\@,$(PACKAGE_VERSION),g' $< > $@
-
CLEANFILES = avahi-core.pc
if HAVE_DBUS
-pkgconfig_DATA += avahi-client.pc
+pkgconfig_DATA += avahi-client.pc avahi-compat-libdns_sd.pc avahi-compat-howl.pc
avahi-client.pc: avahi-client.pc.in
sed -e 's,@prefix\@,$(prefix),g' \
-e 's,@PACKAGE_VERSION\@,$(PACKAGE_VERSION),g' $< > $@
-CLEANFILES += avahi-client.pc
+avahi-compat-libdns_sd.pc: avahi-compat-libdns_sd.pc.in
+ sed -e 's,@prefix\@,$(prefix),g' \
+ -e 's,@PACKAGE_VERSION\@,$(PACKAGE_VERSION),g' $< > $@
+
+avahi-compat-howl.pc: avahi-compat-howl.pc.in
+ sed -e 's,@prefix\@,$(prefix),g' \
+ -e 's,@PACKAGE_VERSION\@,$(PACKAGE_VERSION),g' $< > $@
+
+CLEANFILES += avahi-client.pc avahi-compat-libdns_sd.pc.in avahi-compat-howl.pc.in
endif