summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorSebastien Estienne <sebastien.estienne@gmail.com>2005-11-19 13:43:03 +0000
committerSebastien Estienne <sebastien.estienne@gmail.com>2005-11-19 13:43:03 +0000
commitb69e2e234993a63234eba9bc4f8bfcd13bb5bd6a (patch)
tree2c2a9a20d6ad3647777e9646c21af62bcc30da4c /Makefile.am
parent1b1e2692e498d7bab5183c344887f83c0a94e4bb (diff)
* doesn't compile mono and python-avahi when dbus is not available
* clean the summary of configure a little git-svn-id: file:///home/lennart/svn/public/avahi/trunk@1013 941a03a8-eaeb-0310-b9a0-b1bbd8fe43fe
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am28
1 files changed, 13 insertions, 15 deletions
diff --git a/Makefile.am b/Makefile.am
index 5690c5b..06ffd25 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -137,6 +137,19 @@ CLEANFILES += avahi-compat-libdns_sd.pc
endif
+if HAVE_MONO
+
+pkgconfig_DATA += avahi-sharp.pc
+
+avahi-sharp.pc: avahi-sharp.pc.in
+ sed -e 's,@prefix\@,$(prefix),g' \
+ -e 's,@PACKAGE_VERSION\@,$(PACKAGE_VERSION),g' \
+ -e 's,@libdir\@,$(libdir),g' $< > $@
+
+CLEANFILES += avahi-sharp.pc
+
+endif
+
endif
if HAVE_GLIB
@@ -175,21 +188,6 @@ CLEANFILES += avahi-qt4.pc
endif
-if HAVE_MONO
-if HAVE_DBUS
-
-pkgconfig_DATA += avahi-sharp.pc
-
-avahi-sharp.pc: avahi-sharp.pc.in
- sed -e 's,@prefix\@,$(prefix),g' \
- -e 's,@PACKAGE_VERSION\@,$(PACKAGE_VERSION),g' \
- -e 's,@libdir\@,$(libdir),g' $< > $@
-
-CLEANFILES += avahi-sharp.pc
-
-endif
-endif
-
MOSTLYCLEANFILES = $(DX_CLEANFILES)
DISTCHECK_CONFIGURE_FLAGS = \