summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJames Willcox <snopr@snorp.net>2007-04-19 23:12:35 +0000
committerJames Willcox <snopr@snorp.net>2007-04-19 23:12:35 +0000
commitbe7ce5a2f7f46e48c391d9b9c7501e4e138fc8c5 (patch)
tree1aa6d6859ee2c35e3c8d15baede61b5cd2592dc6 /Makefile.am
parent3025a26988fe2de9d14867056c945e20f490ec1e (diff)
add a makefile rule for zssh.exe, and add a .pc file for avahi-ui-sharp
git-svn-id: file:///home/lennart/svn/public/avahi/trunk@1445 941a03a8-eaeb-0310-b9a0-b1bbd8fe43fe
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am13
1 files changed, 10 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index bc51911..0411c74 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -45,6 +45,7 @@ EXTRA_DIST = \
avahi-qt3.pc.in \
avahi-qt4.pc.in \
avahi-sharp.pc.in \
+ avahi-ui-sharp.pc.in \
avahi-compat-libdns_sd.pc.in \
avahi-compat-howl.pc.in \
avahi-ui.pc.in
@@ -70,7 +71,8 @@ SUBDIRS = \
avahi-compat-libdns_sd \
avahi-compat-howl \
avahi-autoipd \
- avahi-ui
+ avahi-ui \
+ avahi-ui-sharp
DX_INPUT = \
$(srcdir)/avahi-common/address.h \
@@ -181,14 +183,19 @@ endif
if HAVE_MONO
-pkgconfig_DATA += avahi-sharp.pc
+pkgconfig_DATA += avahi-sharp.pc avahi-ui-sharp.pc
avahi-sharp.pc: avahi-sharp.pc.in
sed -e 's,@prefix\@,$(prefix),g' \
-e 's,@PACKAGE_VERSION\@,$(PACKAGE_VERSION),g' \
-e 's,@libdir\@,$(libdir),g' $< > $@
-CLEANFILES += avahi-sharp.pc
+avahi-ui-sharp.pc: avahi-ui-sharp.pc.in
+ sed -e 's,@prefix\@,$(prefix),g' \
+ -e 's,@PACKAGE_VERSION\@,$(PACKAGE_VERSION),g' \
+ -e 's,@libdir\@,$(libdir),g' $< > $@
+
+CLEANFILES += avahi-sharp.pc avahi-ui-sharp.pc
endif