summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorSebastien Estienne <sebastien.estienne@gmail.com>2005-07-28 01:50:16 +0000
committerSebastien Estienne <sebastien.estienne@gmail.com>2005-07-28 01:50:16 +0000
commit8a1b97fd1f8922d0ea07b6c19900a912b2ce7939 (patch)
tree98ff96e4081b6f8939f5fb34bfc9b639c004c817 /Makefile.am
parent86c3e9b7575e5d27f167fc3207fa3936240e8ecd (diff)
* autodetect doxygen based on http://ben-kiki.org/oren/doxample/
git-svn-id: file:///home/lennart/svn/public/avahi/trunk@182 941a03a8-eaeb-0310-b9a0-b1bbd8fe43fe
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 7 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index f59f886..31c54c4 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -16,14 +16,16 @@
# License along with avahi; if not, write to the Free Software
# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307
# USA.
+include aminclude.am
-EXTRA_DIST = bootstrap.sh LICENSE
-SUBDIRS = avahi-common avahi-core avahi-discover avahi-client avahi-daemon doxygen initscript avahi-dnsconfd
+EXTRA_DIST = bootstrap.sh LICENSE $(DX_CONFIG)
+SUBDIRS = avahi-common avahi-core avahi-discover avahi-client avahi-daemon initscript avahi-dnsconfd
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = avahi-core.pc
-doxygen:
- $(MAKE) -C doxygen doxygen
+MOSTLYCLEANFILES = $(DX_CLEANFILES)
-.PHONY: distcleancheck doxygen
+all: doxygen-doc
+
+.PHONY: distcleancheck