summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJames Willcox <snopr@snorp.net>2005-09-09 19:37:21 +0000
committerJames Willcox <snopr@snorp.net>2005-09-09 19:37:21 +0000
commit913d48e3c8e7b27ba4c09282c0c31145a7d4aaee (patch)
tree2338421722db940665e275fa3b7215c36377eb3f /Makefile.am
parent6145338b085810b15f30925fd4404820c8204180 (diff)
move avahi-sharp.pc to the root directory
git-svn-id: file:///home/lennart/svn/public/avahi/trunk@546 941a03a8-eaeb-0310-b9a0-b1bbd8fe43fe
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am15
1 files changed, 14 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index ace4a05..f3bff8f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -40,7 +40,8 @@ EXTRA_DIST = \
avahi-client.pc.in \
avahi-glib.pc.in \
avahi-qt3.pc.in \
- avahi-qt4.pc.in
+ avahi-qt4.pc.in \
+ avahi-sharp.pc.in
SUBDIRS = \
common \
@@ -144,6 +145,18 @@ CLEANFILES += avahi-qt4.pc
endif
+if HAVE_MONO
+
+pkgconfig_DATA += avahi-sharp.pc
+
+avahi-sharp.pc: avahi-sharp.pc.in
+ sed -e 's,@prefix\@,$(prefix),g' \
+ -e 's,@PACKAGE_VERSION\@,$(PACKAGE_VERSION),g' \
+ -e 's,@libdir\@,$(libdir),g' $< > $@
+
+CLEANFILES += avahi-sharp.pc
+
+endif
MOSTLYCLEANFILES = $(DX_CLEANFILES)