summaryrefslogtreecommitdiffstats
path: root/avahi-autoipd/Makefile.am
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2006-09-02 14:45:59 +0000
committerLennart Poettering <lennart@poettering.net>2006-09-02 14:45:59 +0000
commitdeb30fa40d8131132d2d05b4439a0d773766f21b (patch)
tree36a6c1b808058396a6c8632f2c3200cd56fcbb1c /avahi-autoipd/Makefile.am
parent40de1a34d5663c55215d56ceaecc1411a6dfd8f8 (diff)
ship dhclient hook scripts for using ipv4ll as fallback solution where DHCP is not available. Only installed on Debian for now, since only Debian provides the necessary hook directories.
git-svn-id: file:///home/lennart/svn/public/avahi/trunk@1311 941a03a8-eaeb-0310-b9a0-b1bbd8fe43fe
Diffstat (limited to 'avahi-autoipd/Makefile.am')
-rw-r--r--avahi-autoipd/Makefile.am28
1 files changed, 27 insertions, 1 deletions
diff --git a/avahi-autoipd/Makefile.am b/avahi-autoipd/Makefile.am
index 2c55241..7fda8c7 100644
--- a/avahi-autoipd/Makefile.am
+++ b/avahi-autoipd/Makefile.am
@@ -45,7 +45,33 @@ avahi_autoipd_LDADD = $(AM_LDADD) $(LIBDAEMON_LIBS)
pkgsysconf_SCRIPTS=avahi-autoipd.action
+if TARGET_DEBIAN
+
+noinst_SCRIPTS = dhclient-enter-hook dhclient-exit-hook
+
+dhclient-enter-hook: dhclient-enter-hook.in
+ sed -e 's,@sbindir\@,$(sbindir),g' $< > $@
+ chmod +x $@
+
+dhclient-exit-hook: dhclient-exit-hook.in
+ sed -e 's,@sbindir\@,$(sbindir),g' $< > $@
+ chmod +x $@
+
+BUILD = dhclient-exit-hook dhclient-enter-hook
+
+dhcliententerdir = $(sysconfdir)/dhcp3/dhclient-enter-hooks.d
+dhclientexitdir = $(sysconfdir)/dhcp3/dhclient-exit-hooks.d
+
+install-exec-hook: dhclient-exit-hook dhclient-enter-hook
+ $(INSTALL) $(srcdir)/dhclient-enter-hook $(DESTDIR)$(dhcliententerdir)/avahi-autoipd
+ $(INSTALL) $(srcdir)/dhclient-exit-hook $(DESTDIR)$(dhclientexitdir)/avahi-autoipd
+
endif
+
+
endif
+endif
+
+EXTRA_DIST=avahi-autoipd.action dhclient-enter-hook.in dhclient-exit-hook.in
-EXTRA_DIST=avahi-autoipd.action
+CLEANFILES=dhclient-enter-hook dhclient-exit-hook