summaryrefslogtreecommitdiffstats
path: root/avahi-client/Makefile.am
diff options
context:
space:
mode:
authorTrent Lloyd <lathiat@bur.st>2005-07-29 02:03:26 +0000
committerTrent Lloyd <lathiat@bur.st>2005-07-29 02:03:26 +0000
commit368ed1a2a0d95964b3f88c70c9a8c5516367f3f7 (patch)
treec6a022c9db082d742dd04d89f314e7629884c7ba /avahi-client/Makefile.am
parentec9c575fb8d6d9ee2f929ad6cd70177e35ba9cd3 (diff)
* Move dbus service #defines to avahi-common/dbus.h
* Move cdecl.h to installed common headers * Remove glib use from avahi-client * Only build avahi-client if dbus is enabled git-svn-id: file:///home/lennart/svn/public/avahi/trunk@190 941a03a8-eaeb-0310-b9a0-b1bbd8fe43fe
Diffstat (limited to 'avahi-client/Makefile.am')
-rw-r--r--avahi-client/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/avahi-client/Makefile.am b/avahi-client/Makefile.am
index 8f9dce0..2d5a654 100644
--- a/avahi-client/Makefile.am
+++ b/avahi-client/Makefile.am
@@ -23,9 +23,15 @@ AM_CFLAGS=-I$(top_srcdir)
AM_CFLAGS+=$(GLIB20_CFLAGS)
AM_LDADD=$(GLIB20_LIBS)
+# DBUS
+AM_CFLAGS+=$(DBUS_CFLAGS)
+AM_LDADD+=$(DBUS_LIBS)
+
# This cool debug trap works on i386/gcc only
AM_CFLAGS+='-DDEBUG_TRAP=__asm__("int $$3")'
+if ENABLE_DBUS
+
avahi_clientincludedir=$(includedir)/avahi-client
avahi_clientinclude_HEADERS = \
@@ -44,3 +50,5 @@ client_test_SOURCES = \
client-test.c
client_test_CFLAGS = $(AM_CFLAGS)
client_test_LDADD = $(AM_LDADD) libavahi-client.la
+
+endif