summaryrefslogtreecommitdiffstats
path: root/avahi-client/Makefile.am
diff options
context:
space:
mode:
authorTrent Lloyd <lathiat@bur.st>2005-08-11 07:31:07 +0000
committerTrent Lloyd <lathiat@bur.st>2005-08-11 07:31:07 +0000
commit7231641e5c53a9d1c255e06a7a134fa60a919f88 (patch)
treeaed7db1bde5e7036c8f3ab224ce70cd5157d703d /avahi-client/Makefile.am
parent8d8721a8d112e7aaf78cea118a9699b7bf9c28b6 (diff)
* Work on avahi-client
- Support for connecting and registering services works - Needs some more error handling (DBus Errors from the daemon) - Needs browser support yet * Fix avahi-utils to pass make dist-check * Add new error codes git-svn-id: file:///home/lennart/svn/public/avahi/trunk@288 941a03a8-eaeb-0310-b9a0-b1bbd8fe43fe
Diffstat (limited to 'avahi-client/Makefile.am')
-rw-r--r--avahi-client/Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/avahi-client/Makefile.am b/avahi-client/Makefile.am
index a01ede2..d42f33d 100644
--- a/avahi-client/Makefile.am
+++ b/avahi-client/Makefile.am
@@ -33,6 +33,9 @@ avahi_clientincludedir=$(includedir)/avahi-client
avahi_clientinclude_HEADERS = \
client.h
+noinst_HEADERS = \
+ internal.h
+
noinst_PROGRAMS = \
client-test
@@ -40,11 +43,12 @@ lib_LTLIBRARIES = \
libavahi-client.la
libavahi_client_la_SOURCES = \
- client.c client.h
+ client.c client.h \
+ entrygroup.c
client_test_SOURCES = \
client-test.c
client_test_CFLAGS = $(AM_CFLAGS)
-client_test_LDADD = $(AM_LDADD) libavahi-client.la
+client_test_LDADD = $(AM_LDADD) libavahi-client.la ../avahi-common/libavahi-common.la
endif