summaryrefslogtreecommitdiffstats
path: root/avahi-client/Makefile.am
diff options
context:
space:
mode:
authorTrent Lloyd <lathiat@bur.st>2005-08-23 21:50:39 +0000
committerTrent Lloyd <lathiat@bur.st>2005-08-23 21:50:39 +0000
commitbb421d3a4e8e9bbf99c340f5559e6fd76dac5196 (patch)
tree2208fdc99af3fe4f6049e1a2a0fb48d8925eb54d /avahi-client/Makefile.am
parent788c921143004a2fdbf3abcba1a59f1693e2e07d (diff)
* avahi-client/
- Create a new function avahi_dbus_bus_get which acts like dbus_bus_get but instead gets a private connection, this solves the bug where you can't have more than one AvahiClient at once because each successive AvahiClient stepped on the DBusWatch handling of the previous due to libdbus liking to recycle its connections. Introduced a new configure option --with-dbus-system-address= if you set this, you likely want it set to unix:path=/some/socket/here The default is /var/run/dbus/system_socket_address, because this path is hard coded into D-BUS itself, and the DBUS_SYSTEM_BUS_ADDRESS environment variable is now supported to change this at runtime which is inline with libdbus. git-svn-id: file:///home/lennart/svn/public/avahi/trunk@432 941a03a8-eaeb-0310-b9a0-b1bbd8fe43fe
Diffstat (limited to 'avahi-client/Makefile.am')
-rw-r--r--avahi-client/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/avahi-client/Makefile.am b/avahi-client/Makefile.am
index cdc4442..75e18a2 100644
--- a/avahi-client/Makefile.am
+++ b/avahi-client/Makefile.am
@@ -39,7 +39,7 @@ libavahi_client_la_SOURCES = \
browser.c \
resolver.c
-libavahi_client_la_CFLAGS = $(AM_CFLAGS) $(DBUS_CFLAGS)
+libavahi_client_la_CFLAGS = $(AM_CFLAGS) $(DBUS_CFLAGS) -DDBUS_SYSTEM_BUS_DEFAULT_ADDRESS=\"$(DBUS_SYSTEM_BUS_DEFAULT_ADDRESS)\"
libavahi_client_la_LIBADD = $(AM_LDADD) $(DBUS_LIBS) ../avahi-common/libavahi-common.la ../avahi-common/libdbus-common-pic.la
libavahi_client_la_LDFLAGS = $(AM_LDFLAGS) -export-dynamic -version-info 1:0:1