summaryrefslogtreecommitdiffstats
path: root/avahi-common/Makefile.am
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2005-06-10 23:26:48 +0000
committerLennart Poettering <lennart@poettering.net>2005-06-10 23:26:48 +0000
commit4e84c06f024cb079710af5bca7f7bc5c6674f076 (patch)
treec012ca3c11f3771a3781725af7b3947c012f71de /avahi-common/Makefile.am
parentce170511234a040ea6f418b168beb3a6e51a1f2c (diff)
* build libavahi-common statically for debugging purposes
git-svn-id: file:///home/lennart/svn/public/avahi/trunk@108 941a03a8-eaeb-0310-b9a0-b1bbd8fe43fe
Diffstat (limited to 'avahi-common/Makefile.am')
-rw-r--r--avahi-common/Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/avahi-common/Makefile.am b/avahi-common/Makefile.am
index 94d373c..1235f92 100644
--- a/avahi-common/Makefile.am
+++ b/avahi-common/Makefile.am
@@ -43,12 +43,21 @@ noinst_PROGRAMS = \
lib_LTLIBRARIES = \
libavahi-common.la
+noinst_LIBRARIES = \
+ libavahi-common-static.a
+
libavahi_common_la_SOURCES = \
address.c address.h \
strlst.c strlst.h \
alternative.c alternative.h \
rr.c rr.h \
util.c util.h
+libavahi_common_la_CFLAGS = $(AM_CFLAGS)
+libavahi_common_la_LIBADD = $(AM_LDADD)
+
+libavahi_common_static_a_SOURCES = $(libavahi_common_la_SOURCES)
+libavahi_common_static_a_CFLAGS = $(AM_CFLAGS)
+libavahi_common_static_a_LIBADD =
strlst_test_SOURCES = \
strlst.c strlst.h \
@@ -67,3 +76,4 @@ domain_test_SOURCES = \
domain-test.c
domain_test_CFLAGS = $(AM_CFLAGS)
domain_test_LDADD = $(AM_LDADD)
+