summaryrefslogtreecommitdiffstats
path: root/avahi-common/Makefile.am
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2005-07-19 18:36:14 +0000
committerLennart Poettering <lennart@poettering.net>2005-07-19 18:36:14 +0000
commitac082e8eb624bc5ae0c19e91f412c8c5f12bfddf (patch)
treeed6541089d847c55395f29d77f7b1aaa1b05f014 /avahi-common/Makefile.am
parent9598fdcd41f23f15bc4e329ef1c4aba912ce5b8a (diff)
* Change timeval arithmetic functions to use 64bit integers. This fixes some problems with long lived queries
git-svn-id: file:///home/lennart/svn/public/avahi/trunk@170 941a03a8-eaeb-0310-b9a0-b1bbd8fe43fe
Diffstat (limited to 'avahi-common/Makefile.am')
-rw-r--r--avahi-common/Makefile.am9
1 files changed, 8 insertions, 1 deletions
diff --git a/avahi-common/Makefile.am b/avahi-common/Makefile.am
index b1188cd..208aa94 100644
--- a/avahi-common/Makefile.am
+++ b/avahi-common/Makefile.am
@@ -41,7 +41,8 @@ noinst_HEADERS = \
noinst_PROGRAMS = \
strlst-test \
domain-test \
- alternative-test
+ alternative-test \
+ timeval-test
lib_LTLIBRARIES = \
libavahi-common.la
@@ -80,3 +81,9 @@ domain_test_SOURCES = \
domain_test_CFLAGS = $(AM_CFLAGS)
domain_test_LDADD = $(AM_LDADD)
+timeval_test_SOURCES = \
+ util.c util.h \
+ timeval-test.c
+timeval_test_CFLAGS = $(AM_CFLAGS)
+timeval_test_LDADD = $(AM_LDADD)
+