summaryrefslogtreecommitdiffstats
path: root/avahi-common/Makefile.am
diff options
context:
space:
mode:
authorTrent Lloyd <lathiat@bur.st>2005-06-04 18:56:52 +0000
committerTrent Lloyd <lathiat@bur.st>2005-06-04 18:56:52 +0000
commitc5544522f6409095627dc3d1129560195ab4ec40 (patch)
treec108416de17f0fa463b6dc9be8878bff1c16a120 /avahi-common/Makefile.am
parent75d26059acb131382779de9b3f880df717f6d2ba (diff)
* Split out a fair bit of avahi-core into avahi-common for use by the client library
git-svn-id: file:///home/lennart/svn/public/avahi/trunk@98 941a03a8-eaeb-0310-b9a0-b1bbd8fe43fe
Diffstat (limited to 'avahi-common/Makefile.am')
-rw-r--r--avahi-common/Makefile.am81
1 files changed, 81 insertions, 0 deletions
diff --git a/avahi-common/Makefile.am b/avahi-common/Makefile.am
new file mode 100644
index 0000000..8c58757
--- /dev/null
+++ b/avahi-common/Makefile.am
@@ -0,0 +1,81 @@
+# $Id: Makefile.am 90 2005-05-23 16:15:12Z lennart $
+#
+# This file is part of avahi.
+#
+# avahi is free software; you can redistribute it and/or modify it
+# under the terms of the GNU Lesser General Public License as
+# published by the Free Software Foundation; either version 2 of the
+# License, or (at your option) any later version.
+#
+# avahi is distributed in the hope that it will be useful, but WITHOUT
+# ANY WARRANTY; without even the implied warranty of MERCHANTABILITY
+# or FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public
+# License for more details.
+#
+# You should have received a copy of the GNU Lesser General Public
+# License along with avahi; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307
+# USA.
+
+AM_CFLAGS=-I$(top_srcdir) -D_GNU_SOURCE
+
+# GLIB 2.0
+AM_CFLAGS+=$(GLIB20_CFLAGS)
+AM_LDADD=$(GLIB20_LIBS)
+
+# This cool debug trap works on i386/gcc only
+AM_CFLAGS+='-DDEBUG_TRAP=__asm__("int $$3")'
+
+avahi_commonincludedir=$(includedir)/avahi-common
+
+avahi_commoninclude_HEADERS =
+ strlst.h \
+ address.h \
+ alternative.h \
+ rr.h \
+ util.h \
+ dns.h
+
+noinst_PROGRAMS = \
+ strlst-test \
+ dns-test \
+ domain-test \
+ alternative-test
+
+lib_LTLIBRARIES = \
+ libavahi-common.la
+
+libavahi_common_la_SOURCES = \
+ address.c address.h \
+ strlst.c strlst.h \
+ alternative.c alternative.h \
+ rr.c rr.h \
+ dns.c dns.h \
+ util.c util.h
+
+strlst_test_SOURCES = \
+ strlst.c strlst.h \
+ strlst-test.c
+strlst_test_CFLAGS = $(AM_CFLAGS)
+strlst_test_LDADD = $(AM_LDADD)
+
+dns_test_SOURCES = \
+ util.c util.h \
+ dns.c dns.h \
+ rr.c rr.h \
+ strlst.c strlst \
+ dns-test.c
+dns_test_CFLAGS = $(AM_CFLAGS)
+dns_test_LDADD = $(AM_LDADD)
+
+alternative_test_SOURCES = \
+ alternative.c alternative.h \
+ alternative-test.c
+alternative_test_CFLAGS = $(AM_CFLAGS)
+alternative_test_LDADD = $(AM_LDADD)
+
+domain_test_SOURCES = \
+ util.c util.h \
+ domain-test.c
+domain_test_CFLAGS = $(AM_CFLAGS)
+domain_test_LDADD = $(AM_LDADD)