summaryrefslogtreecommitdiffstats
path: root/avahi-compat-howl/Makefile.am
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2005-10-13 01:26:32 +0000
committerLennart Poettering <lennart@poettering.net>2005-10-13 01:26:32 +0000
commit0e203251414d56b3f6b8d4dafde19a1d27b18caf (patch)
treeff8e355063f6a97c18750d06378132fc63dcfd7a /avahi-compat-howl/Makefile.am
parent32a03550ac3a6272595866fd40389b8ee3fad9e8 (diff)
implement address related functions
git-svn-id: file:///home/lennart/svn/public/avahi/trunk@753 941a03a8-eaeb-0310-b9a0-b1bbd8fe43fe
Diffstat (limited to 'avahi-compat-howl/Makefile.am')
-rw-r--r--avahi-compat-howl/Makefile.am20
1 files changed, 11 insertions, 9 deletions
diff --git a/avahi-compat-howl/Makefile.am b/avahi-compat-howl/Makefile.am
index 123cdd7..8d0f1dd 100644
--- a/avahi-compat-howl/Makefile.am
+++ b/avahi-compat-howl/Makefile.am
@@ -49,22 +49,24 @@ avahi_compat_howl_HEADERS = \
lib_LTLIBRARIES = libavahi-compat-howl.la
-#noinst_PROGRAMS = txt-test
+noinst_PROGRAMS = address-test
libavahi_compat_howl_la_SOURCES = \
$(avahi_compat_howl_HEADERS) \
warn.c warn.h \
- unsupported.c
+ unsupported.c \
+ address.c \
+ text.c
libavahi_compat_howl_la_CFLAGS = $(AM_CFLAGS) $(PTHREAD_CFLAGS) -I $(srcdir)/include
libavahi_compat_howl_la_LDFLAGS = $(AM_LDFLAGS) -export-dynamic -version-info $(LIBAVAHI_COMPAT_HOWL_VERSION_INFO) $(PTHREAD_LIBS) ../avahi-common/libavahi-common.la ../avahi-client/libavahi-client.la
-#txt_test_SOURCES = \
-# dns_sd.h \
-# txt.c \
-# txt-test.c \
-# warn.c warn.h
-#txt_test_CFLAGS = $(AM_CFLAGS) $(PTHREAD_CFLAGS)
-#txt_test_LDADD = $(AM_LDADD) ../avahi-common/libavahi-common.la
+address_test_SOURCES = \
+ $(avahi_compat_howl_HEADERS) \
+ address.c \
+ address-test.c \
+ warn.c warn.h
+address_test_CFLAGS = $(AM_CFLAGS) $(PTHREAD_CFLAGS) -I $(srcdir)/include
+address_test_LDADD = $(AM_LDADD) ../avahi-common/libavahi-common.la
# You can test the compatibility layer by sticking in mDNSResponder's
# dns-sd.c source here, naming it "libdns_sd-test.c" and running "make