summaryrefslogtreecommitdiffstats
path: root/avahi-compat-howl/Makefile.am
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2005-10-13 02:34:19 +0000
committerLennart Poettering <lennart@poettering.net>2005-10-13 02:34:19 +0000
commit0433169ea9c6906f31b1a78e9a118858dd776dad (patch)
treeb45c627c8e2001f1ce5295a3312b3c06f97054cf /avahi-compat-howl/Makefile.am
parent0e203251414d56b3f6b8d4dafde19a1d27b18caf (diff)
* implement HOWL TXT functions
* return SW_E_NO_IMPL instead of SW_DISCOVERY_E_NOT_SUPPORTED in unsupported HOWL functions git-svn-id: file:///home/lennart/svn/public/avahi/trunk@754 941a03a8-eaeb-0310-b9a0-b1bbd8fe43fe
Diffstat (limited to 'avahi-compat-howl/Makefile.am')
-rw-r--r--avahi-compat-howl/Makefile.am11
1 files changed, 10 insertions, 1 deletions
diff --git a/avahi-compat-howl/Makefile.am b/avahi-compat-howl/Makefile.am
index 8d0f1dd..398f029 100644
--- a/avahi-compat-howl/Makefile.am
+++ b/avahi-compat-howl/Makefile.am
@@ -49,7 +49,7 @@ avahi_compat_howl_HEADERS = \
lib_LTLIBRARIES = libavahi-compat-howl.la
-noinst_PROGRAMS = address-test
+noinst_PROGRAMS = address-test text-test
libavahi_compat_howl_la_SOURCES = \
$(avahi_compat_howl_HEADERS) \
@@ -68,6 +68,15 @@ address_test_SOURCES = \
address_test_CFLAGS = $(AM_CFLAGS) $(PTHREAD_CFLAGS) -I $(srcdir)/include
address_test_LDADD = $(AM_LDADD) ../avahi-common/libavahi-common.la
+text_test_SOURCES = \
+ $(avahi_compat_howl_HEADERS) \
+ text.c \
+ text-test.c \
+ warn.c warn.h
+text_test_CFLAGS = $(AM_CFLAGS) $(PTHREAD_CFLAGS) -I $(srcdir)/include
+text_test_LDADD = $(AM_LDADD) ../avahi-common/libavahi-common.la
+
+
# You can test the compatibility layer by sticking in mDNSResponder's
# dns-sd.c source here, naming it "libdns_sd-test.c" and running "make
# libdns_sd-test" manually. We do not distribute that file due to