summaryrefslogtreecommitdiffstats
path: root/avahi-compat-howl/Makefile.am
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2005-10-19 00:10:02 +0000
committerLennart Poettering <lennart@poettering.net>2005-10-19 00:10:02 +0000
commit16d9e30dd7fa052bd7e6dd37927d7f27bec90ef1 (patch)
treed52fcd4dfde907c278a29c76e59f899c92c1a4b4 /avahi-compat-howl/Makefile.am
parentd266407d3e6d8f2a8e14e8bd2f89fa8a4333613c (diff)
* Compile tests only when --enable-tests was specified on the configure command line
* Build compat layers only when --enable-compat-{howl,libdns_sd} was passed to configure * drop avahi_strlcpy() to reduce our code/API size * replace getifname() with if_indextoname in avahi-dnsconfd * declare environ if needed in avahi-dnsconfd * drop some useless definitions like AVAHI_PUBLISH_NULL = 0 git-svn-id: file:///home/lennart/svn/public/avahi/trunk@819 941a03a8-eaeb-0310-b9a0-b1bbd8fe43fe
Diffstat (limited to 'avahi-compat-howl/Makefile.am')
-rw-r--r--avahi-compat-howl/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/avahi-compat-howl/Makefile.am b/avahi-compat-howl/Makefile.am
index 5c12782..e183b7e 100644
--- a/avahi-compat-howl/Makefile.am
+++ b/avahi-compat-howl/Makefile.am
@@ -25,6 +25,7 @@ AM_CFLAGS+='-DDEBUG_TRAP=__asm__("int $$3")'
SUBDIRS = . samples
if HAVE_DBUS
+if ENABLE_COMPAT_HOWL
avahi_compat_howldir=$(includedir)/avahi-compat-howl
avahi_compat_howl_rendezvousdir=$(avahi_compat_howldir)/rendezvous
@@ -70,7 +71,9 @@ HOWLHEADERS = \
lib_LTLIBRARIES = libavahi-compat-howl.la
+if ENABLE_TESTS
noinst_PROGRAMS = address-test text-test browse-domain-test
+endif
libavahi_compat_howl_la_SOURCES = \
$(HOWLHEADERS) \
@@ -105,3 +108,4 @@ browse_domain_test_CFLAGS = $(AM_CFLAGS) $(PTHREAD_CFLAGS) -I $(srcdir)/include
browse_domain_test_LDADD = $(AM_LDADD) libavahi-compat-howl.la
endif
+endif