summaryrefslogtreecommitdiffstats
path: root/avahi-core/Makefile.am
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2005-10-12 13:39:48 +0000
committerLennart Poettering <lennart@poettering.net>2005-10-12 13:39:48 +0000
commit1496b98f1bdf4e489fd3b16c6b113f9463a0a0bb (patch)
tree95dd5639b26687d616cbb8d832ac64cbfe559299 /avahi-core/Makefile.am
parentc2c6f999b78be193cad9a74271877f2bc6891c1f (diff)
minor Makefile.am cleanup
git-svn-id: file:///home/lennart/svn/public/avahi/trunk@735 941a03a8-eaeb-0310-b9a0-b1bbd8fe43fe
Diffstat (limited to 'avahi-core/Makefile.am')
-rw-r--r--avahi-core/Makefile.am16
1 files changed, 7 insertions, 9 deletions
diff --git a/avahi-core/Makefile.am b/avahi-core/Makefile.am
index e525c1c..14b161a 100644
--- a/avahi-core/Makefile.am
+++ b/avahi-core/Makefile.am
@@ -44,19 +44,12 @@ noinst_PROGRAMS = \
hashmap-test \
querier-test
-if HAVE_NETLINK
-NETLINK = \
- iface-linux.c iface-linux.h \
- netlink.c netlink.h
-endif
-
libavahi_core_la_SOURCES = \
timeeventq.c timeeventq.h\
iface.c iface.h \
- $(NETLINK) \
server.c server.h \
prioq.c prioq.h \
- cache.c cache.h\
+ cache.c cache.h \
socket.c socket.h \
response-sched.c response-sched.h \
query-sched.c query-sched.h \
@@ -81,7 +74,12 @@ libavahi_core_la_SOURCES = \
wide-area.c wide-area.h \
multicast-lookup.c multicast-lookup.h \
querier.c querier.h
-
+
+if HAVE_NETLINK
+libavahi_core_la_SOURCES += \
+ iface-linux.c iface-linux.h \
+ netlink.c netlink.h
+endif
libavahi_core_la_CFLAGS = $(AM_CFLAGS)
libavahi_core_la_LIBADD = $(AM_LDADD) ../avahi-common/libavahi-common.la