summaryrefslogtreecommitdiffstats
path: root/avahi-core/Makefile.am
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2005-10-19 00:10:02 +0000
committerLennart Poettering <lennart@poettering.net>2005-10-19 00:10:02 +0000
commit16d9e30dd7fa052bd7e6dd37927d7f27bec90ef1 (patch)
treed52fcd4dfde907c278a29c76e59f899c92c1a4b4 /avahi-core/Makefile.am
parentd266407d3e6d8f2a8e14e8bd2f89fa8a4333613c (diff)
* Compile tests only when --enable-tests was specified on the configure command line
* Build compat layers only when --enable-compat-{howl,libdns_sd} was passed to configure * drop avahi_strlcpy() to reduce our code/API size * replace getifname() with if_indextoname in avahi-dnsconfd * declare environ if needed in avahi-dnsconfd * drop some useless definitions like AVAHI_PUBLISH_NULL = 0 git-svn-id: file:///home/lennart/svn/public/avahi/trunk@819 941a03a8-eaeb-0310-b9a0-b1bbd8fe43fe
Diffstat (limited to 'avahi-core/Makefile.am')
-rw-r--r--avahi-core/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/avahi-core/Makefile.am b/avahi-core/Makefile.am
index 3ecce11..9516615 100644
--- a/avahi-core/Makefile.am
+++ b/avahi-core/Makefile.am
@@ -34,6 +34,7 @@ avahiinclude_HEADERS = \
lib_LTLIBRARIES = \
libavahi-core.la
+if ENABLE_TESTS
noinst_PROGRAMS = \
prioq-test \
avahi-test \
@@ -44,6 +45,7 @@ noinst_PROGRAMS = \
hashmap-test \
querier-test \
update-test
+endif
libavahi_core_la_SOURCES = \
timeeventq.c timeeventq.h\