summaryrefslogtreecommitdiffstats
path: root/avahi-core/Makefile.am
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2005-09-25 20:12:40 +0000
committerLennart Poettering <lennart@poettering.net>2005-09-25 20:12:40 +0000
commit1ffedb586bd2fb6daa3970304fac7c5b415cd38f (patch)
treef084dcd2594490b7e95ab026ad2efeaeab3f998a /avahi-core/Makefile.am
parent5867849876e19996fd05a0d4917cb739904519c1 (diff)
* split off lookup.h and publish.h from core.h
* implement wide-area DNS-SD * if multiple clients query the same records, only start the query packet sequence once * implement recursive CNAME queries * add support for resolving services without TXT or A/AAAA records * enlarge resolving timeouts to 5s * implement new browse/resolving events CACHE_EXHAUSTED/ALL_FOR_NOW * add support for resolving services without name. (i.e. for normal SRV records) git-svn-id: file:///home/lennart/svn/public/avahi/trunk@608 941a03a8-eaeb-0310-b9a0-b1bbd8fe43fe
Diffstat (limited to 'avahi-core/Makefile.am')
-rw-r--r--avahi-core/Makefile.am20
1 files changed, 16 insertions, 4 deletions
diff --git a/avahi-core/Makefile.am b/avahi-core/Makefile.am
index 59b6215..9a2c098 100644
--- a/avahi-core/Makefile.am
+++ b/avahi-core/Makefile.am
@@ -27,7 +27,9 @@ avahiincludedir=$(includedir)/avahi-core
avahiinclude_HEADERS = \
core.h \
log.h \
- rr.h
+ rr.h \
+ publish.h \
+ lookup.h
lib_LTLIBRARIES = \
libavahi-core.la
@@ -39,7 +41,8 @@ noinst_PROGRAMS = \
avahi-reflector \
dns-test \
timeeventq-test \
- hashmap-test
+ hashmap-test \
+ querier-test
libavahi_core_la_SOURCES = \
timeeventq.c timeeventq.h\
@@ -63,12 +66,15 @@ libavahi_core_la_SOURCES = \
resolve-service.c \
dns.c dns.h \
rr.c rr.h \
- core.h \
+ core.h lookup.h publish.h \
log.c log.h \
browse-dns-server.c \
fdutil.h fdutil.c \
util.c util.h \
- hashmap.c hashmap.h
+ hashmap.c hashmap.h \
+ wide-area.c wide-area.h \
+ multicast-lookup.c multicast-lookup.h \
+ querier.c querier.h
libavahi_core_la_CFLAGS = $(AM_CFLAGS)
libavahi_core_la_LIBADD = $(AM_LDADD) ../avahi-common/libavahi-common.la
@@ -85,6 +91,12 @@ avahi_test_SOURCES = \
avahi_test_CFLAGS = $(AM_CFLAGS)
avahi_test_LDADD = $(AM_LDADD) ../avahi-common/libavahi-common.la libavahi-core.la
+
+querier_test_SOURCES = \
+ querier-test.c
+querier_test_CFLAGS = $(AM_CFLAGS)
+querier_test_LDADD = $(AM_LDADD) ../avahi-common/libavahi-common.la libavahi-core.la
+
conformance_test_SOURCES = \
conformance-test.c
conformance_test_CFLAGS = $(AM_CFLAGS)