summaryrefslogtreecommitdiffstats
path: root/avahi-core/Makefile.am
diff options
context:
space:
mode:
authorRob Leslie <rob@mars.org>2009-03-03 21:37:15 -0800
committerLennart Poettering <lennart@poettering.net>2009-04-19 01:11:15 +0200
commit2ea7e99ed0dcfd371fef5aeecd3de77da1dfcd4f (patch)
tree52d29835ce1ab9db44248ea37f2e19f835b9e310 /avahi-core/Makefile.am
parentfd5bae5a6626956acd11995628fb83e7e8182c1f (diff)
reflector: Don't reflect link-local IPv4 or IPv6 addresses
Modify avahi-daemon so that it doesn't advertise patently useless link-local addresses on the wrong interfaces when reflecting mDNS responses.
Diffstat (limited to 'avahi-core/Makefile.am')
-rw-r--r--avahi-core/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/avahi-core/Makefile.am b/avahi-core/Makefile.am
index d190c66..3062cc6 100644
--- a/avahi-core/Makefile.am
+++ b/avahi-core/Makefile.am
@@ -143,7 +143,8 @@ dns_test_SOURCES = \
util.c util.h \
rr.c rr.h \
hashmap.c hashmap.h \
- domain-util.c domain-util.h
+ domain-util.c domain-util.h \
+ addr-util.c addr-util.h
dns_test_CFLAGS = $(AM_CFLAGS)
dns_test_LDADD = $(AM_LDADD) ../avahi-common/libavahi-common.la