summaryrefslogtreecommitdiffstats
path: root/avahi-core/Makefile.am
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2005-10-17 00:20:33 +0000
committerLennart Poettering <lennart@poettering.net>2005-10-17 00:20:33 +0000
commit41f2725b37437a585ce285051bdae06f4919dc3b (patch)
tree1820274ac232dd46b907f98e9119be04eba43feb /avahi-core/Makefile.am
parent58ca874e460691615b131ad8692165a12f14bd09 (diff)
* implement record updating through the new flags AVAHI_PUBLISH_UPDATE
* add new helper function avahi_server_update_service_txt() to ease TXT record updating for services * other minor cleanups git-svn-id: file:///home/lennart/svn/public/avahi/trunk@790 941a03a8-eaeb-0310-b9a0-b1bbd8fe43fe
Diffstat (limited to 'avahi-core/Makefile.am')
-rw-r--r--avahi-core/Makefile.am9
1 files changed, 7 insertions, 2 deletions
diff --git a/avahi-core/Makefile.am b/avahi-core/Makefile.am
index 14b161a..b62a4d5 100644
--- a/avahi-core/Makefile.am
+++ b/avahi-core/Makefile.am
@@ -42,7 +42,8 @@ noinst_PROGRAMS = \
dns-test \
timeeventq-test \
hashmap-test \
- querier-test
+ querier-test \
+ update-test
libavahi_core_la_SOURCES = \
timeeventq.c timeeventq.h\
@@ -74,7 +75,7 @@ libavahi_core_la_SOURCES = \
wide-area.c wide-area.h \
multicast-lookup.c multicast-lookup.h \
querier.c querier.h
-
+
if HAVE_NETLINK
libavahi_core_la_SOURCES += \
iface-linux.c iface-linux.h \
@@ -96,6 +97,10 @@ avahi_test_SOURCES = \
avahi_test_CFLAGS = $(AM_CFLAGS)
avahi_test_LDADD = $(AM_LDADD) ../avahi-common/libavahi-common.la libavahi-core.la
+update_test_SOURCES = \
+ update-test.c
+update_test_CFLAGS = $(AM_CFLAGS)
+update_test_LDADD = $(AM_LDADD) ../avahi-common/libavahi-common.la libavahi-core.la
querier_test_SOURCES = \
querier-test.c