summaryrefslogtreecommitdiffstats
path: root/avahi-core/Makefile.am
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2005-06-10 23:26:48 +0000
committerLennart Poettering <lennart@poettering.net>2005-06-10 23:26:48 +0000
commit4e84c06f024cb079710af5bca7f7bc5c6674f076 (patch)
treec012ca3c11f3771a3781725af7b3947c012f71de /avahi-core/Makefile.am
parentce170511234a040ea6f418b168beb3a6e51a1f2c (diff)
* build libavahi-common statically for debugging purposes
git-svn-id: file:///home/lennart/svn/public/avahi/trunk@108 941a03a8-eaeb-0310-b9a0-b1bbd8fe43fe
Diffstat (limited to 'avahi-core/Makefile.am')
-rw-r--r--avahi-core/Makefile.am15
1 files changed, 9 insertions, 6 deletions
diff --git a/avahi-core/Makefile.am b/avahi-core/Makefile.am
index 6fb0839..ca7c385 100644
--- a/avahi-core/Makefile.am
+++ b/avahi-core/Makefile.am
@@ -25,7 +25,8 @@ AM_LDADD=$(GLIB20_LIBS)
# Import stuff from avahi-common
AM_CFLAGS+=-I$(top_srcdir)/avahi-common
-AM_LDADD+=../avahi-common/libavahi-common.la
+COMMON_LDADD=../avahi-common/libavahi-common.la
+STATIC_COMMON_LDADD=../avahi-common/libavahi-common-static.a
# This cool debug trap works on i386/gcc only
AM_CFLAGS+='-DDEBUG_TRAP=__asm__("int $$3")'
@@ -68,36 +69,38 @@ libavahi_core_la_SOURCES = \
dns.c dns.h \
core.h \
llist.h
+libavahi_core_la_CFLAGS = $(AM_CFLAGS)
+libavahi_core_la_LIBADD = $(AM_LDADD) $(COMMON_LDADD)
prioq_test_SOURCES = \
prioq-test.c \
prioq.c prioq.h
prioq_test_CFLAGS = $(AM_CFLAGS)
-prioq_test_LDADD = $(AM_LDADD)
+prioq_test_LDADD = $(AM_LDADD) $(STATIC_COMMON_LDADD)
avahi_test_SOURCES = \
avahi-test.c \
$(libavahi_core_la_SOURCES)
avahi_test_CFLAGS = $(AM_CFLAGS)
-avahi_test_LDADD = $(AM_LDADD)
+avahi_test_LDADD = $(AM_LDADD) $(STATIC_COMMON_LDADD)
conformance_test_SOURCES = \
conformance-test.c \
$(libavahi_core_la_SOURCES)
conformance_test_CFLAGS = $(AM_CFLAGS)
-conformance_test_LDADD = $(AM_LDADD)
+conformance_test_LDADD = $(AM_LDADD) $(STATIC_COMMON_LDADD)
avahi_reflector_SOURCES = \
avahi-reflector.c \
$(libavahi_core_la_SOURCES)
avahi_reflector_CFLAGS = $(AM_CFLAGS)
-avahi_reflector_LDADD = $(AM_LDADD)
+avahi_reflector_LDADD = $(AM_LDADD) $(STATIC_COMMON_LDADD)
dns_test_SOURCES = \
dns.c dns.h \
dns-test.c
dns_test_CFLAGS = $(AM_CFLAGS)
-dns_test_LDADD = $(AM_LDADD)
+dns_test_LDADD = $(AM_LDADD) $(STATIC_COMMON_LDADD)
valgrind: avahi-test
libtool --mode=execute valgrind ./avahi-test