summaryrefslogtreecommitdiffstats
path: root/avahi-core/Makefile.am
diff options
context:
space:
mode:
authorSebastien Estienne <sebastien.estienne@gmail.com>2005-10-17 20:41:59 +0000
committerSebastien Estienne <sebastien.estienne@gmail.com>2005-10-17 20:41:59 +0000
commit55f7dcb690bcbdf6bca6568e0d9aacb2456811a5 (patch)
treebfca70d02d516beca0fda35a2148337e16c32f4d /avahi-core/Makefile.am
parent11fdf8612c684b0faf85781ef1b2766bf6ea1f0b (diff)
* autotools magic for PF_ROUTE (not the real thing yet).
git-svn-id: file:///home/lennart/svn/public/avahi/trunk@802 941a03a8-eaeb-0310-b9a0-b1bbd8fe43fe
Diffstat (limited to 'avahi-core/Makefile.am')
-rw-r--r--avahi-core/Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/avahi-core/Makefile.am b/avahi-core/Makefile.am
index 1a78368..95505b8 100644
--- a/avahi-core/Makefile.am
+++ b/avahi-core/Makefile.am
@@ -80,6 +80,11 @@ if HAVE_NETLINK
libavahi_core_la_SOURCES += \
iface-linux.c iface-linux.h \
netlink.c netlink.h
+else
+if HAVE_PF_ROUTE
+libavahi_core_la_SOURCES += \
+ iface-pfroute.c iface-pfroute.h
+endif
endif
libavahi_core_la_CFLAGS = $(AM_CFLAGS)