summaryrefslogtreecommitdiffstats
path: root/avahi-core/Makefile.am
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2005-08-12 00:25:52 +0000
committerLennart Poettering <lennart@poettering.net>2005-08-12 00:25:52 +0000
commit5ebf655c85076f200955458673a8bbf0dd927407 (patch)
tree148d2a476b375603db4e3401b8d1d1236af0ae2c /avahi-core/Makefile.am
parente63a65b3955b173a3e8d6b78c6377a518a9922d6 (diff)
Split avahi-common/util.h into
avahi-common/domain.h avahi-core/fdutil.h avahi-core/timeval.h git-svn-id: file:///home/lennart/svn/public/avahi/trunk@299 941a03a8-eaeb-0310-b9a0-b1bbd8fe43fe
Diffstat (limited to 'avahi-core/Makefile.am')
-rw-r--r--avahi-core/Makefile.am16
1 files changed, 14 insertions, 2 deletions
diff --git a/avahi-core/Makefile.am b/avahi-core/Makefile.am
index 2e436a6..e15f295 100644
--- a/avahi-core/Makefile.am
+++ b/avahi-core/Makefile.am
@@ -46,7 +46,8 @@ noinst_PROGRAMS = \
conformance-test \
avahi-reflector \
dns-test \
- timeeventq-test
+ timeeventq-test \
+ timeval-test
libavahi_core_la_SOURCES = \
timeeventq.c timeeventq.h\
@@ -72,7 +73,10 @@ libavahi_core_la_SOURCES = \
rr.c rr.h \
core.h \
log.c log.h \
- browse-dns-server.c
+ browse-dns-server.c \
+ fdutil.h fdutil.c \
+ timeval.h timeval.c \
+ util.c util.h
libavahi_core_la_CFLAGS = $(AM_CFLAGS)
libavahi_core_la_LIBADD = $(AM_LDADD) $(COMMON_LDADD)
@@ -101,6 +105,7 @@ dns_test_SOURCES = \
dns.c dns.h \
dns-test.c \
log.c log.h \
+ util.c util.h \
rr.c rr.h
dns_test_CFLAGS = $(AM_CFLAGS)
dns_test_LDADD = $(AM_LDADD) $(COMMON_LDADD)
@@ -108,10 +113,17 @@ dns_test_LDADD = $(AM_LDADD) $(COMMON_LDADD)
timeeventq_test_SOURCES = \
timeeventq-test.c \
timeeventq.h timeeventq.c \
+ timeval.c timeval.h \
prioq.h prioq.c
timeeventq_test_CFLAGS = $(AM_CFLAGS)
timeeventq_test_LDADD = $(AM_LDADD) $(COMMON_LDADD)
+timeval_test_SOURCES = \
+ timeval.c timeval.h \
+ timeval-test.c
+timeval_test_CFLAGS = $(AM_CFLAGS)
+timeval_test_LDADD = $(AM_LDADD)
+
valgrind: avahi-test
libtool --mode=execute valgrind ./avahi-test