summaryrefslogtreecommitdiffstats
path: root/avahi-core/Makefile.am
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2005-08-12 21:01:28 +0000
committerLennart Poettering <lennart@poettering.net>2005-08-12 21:01:28 +0000
commit6e35536bddb52c8e6bc201265c77a846d879b5a3 (patch)
treef00a3475d91759f1fe3d36df2757cc8f230e9234 /avahi-core/Makefile.am
parent5d047523c87ba11aad8c384f7ffde25b4dd746ed (diff)
* implement hashmap
* de-glib-ify rr.[ch], rrlist.[ch] git-svn-id: file:///home/lennart/svn/public/avahi/trunk@306 941a03a8-eaeb-0310-b9a0-b1bbd8fe43fe
Diffstat (limited to 'avahi-core/Makefile.am')
-rw-r--r--avahi-core/Makefile.am16
1 files changed, 13 insertions, 3 deletions
diff --git a/avahi-core/Makefile.am b/avahi-core/Makefile.am
index c71d6ed..e0e7d86 100644
--- a/avahi-core/Makefile.am
+++ b/avahi-core/Makefile.am
@@ -45,7 +45,8 @@ noinst_PROGRAMS = \
conformance-test \
avahi-reflector \
dns-test \
- timeeventq-test
+ timeeventq-test \
+ hashmap-test
libavahi_core_la_SOURCES = \
timeeventq.c timeeventq.h\
@@ -73,7 +74,8 @@ libavahi_core_la_SOURCES = \
log.c log.h \
browse-dns-server.c \
fdutil.h fdutil.c \
- util.c util.h
+ util.c util.h \
+ hashmap.c hashmap.h
libavahi_core_la_CFLAGS = $(AM_CFLAGS)
libavahi_core_la_LIBADD = $(AM_LDADD) $(COMMON_LDADD)
@@ -104,7 +106,8 @@ dns_test_SOURCES = \
dns-test.c \
log.c log.h \
util.c util.h \
- rr.c rr.h
+ rr.c rr.h \
+ hashmap.c hashmap.h
dns_test_CFLAGS = $(AM_CFLAGS)
dns_test_LDADD = $(AM_LDADD) $(COMMON_LDADD)
@@ -115,6 +118,13 @@ timeeventq_test_SOURCES = \
timeeventq_test_CFLAGS = $(AM_CFLAGS)
timeeventq_test_LDADD = $(AM_LDADD) $(COMMON_LDADD)
+hashmap_test_SOURCES = \
+ hashmap-test.c \
+ hashmap.h hashmap.c \
+ util.h util.c
+hashmap_test_CFLAGS = $(AM_CFLAGS)
+hashmap_test_LDADD = $(AM_LDADD) $(COMMON_LDADD)
+
valgrind: avahi-test
libtool --mode=execute valgrind ./avahi-test