summaryrefslogtreecommitdiffstats
path: root/avahi-core/Makefile.am
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2007-04-12 23:40:57 +0000
committerLennart Poettering <lennart@poettering.net>2007-04-12 23:40:57 +0000
commit76827819636d9a2d66a9e2ad042aaed1fbf952db (patch)
tree8f4fa84a95d8e66420efa1838ae5d9459ba96c30 /avahi-core/Makefile.am
parent2bbdbf1155cca40d5c89ef4fcd4db40f655b0a93 (diff)
add a regression test for #84 contributed by tedp. (closes #84)
git-svn-id: file:///home/lennart/svn/public/avahi/trunk@1420 941a03a8-eaeb-0310-b9a0-b1bbd8fe43fe
Diffstat (limited to 'avahi-core/Makefile.am')
-rw-r--r--avahi-core/Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/avahi-core/Makefile.am b/avahi-core/Makefile.am
index cb2d8f9..6e1d992 100644
--- a/avahi-core/Makefile.am
+++ b/avahi-core/Makefile.am
@@ -41,10 +41,16 @@ noinst_PROGRAMS = \
conformance-test \
avahi-reflector \
dns-test \
+ dns-spin-test \
timeeventq-test \
hashmap-test \
querier-test \
update-test
+
+TESTS = \
+ dns-spin-test \
+ dns-test \
+ hashmap-test
endif
libavahi_core_la_SOURCES = \
@@ -138,6 +144,11 @@ dns_test_SOURCES = \
dns_test_CFLAGS = $(AM_CFLAGS)
dns_test_LDADD = $(AM_LDADD) ../avahi-common/libavahi-common.la
+dns_spin_test_SOURCES = \
+ dns-spin-test.c
+dns_spin_test_CFLAGS = $(AM_CFLAGS)
+dns_spin_test_LDADD = $(AM_LDADD) libavahi-core.la
+
timeeventq_test_SOURCES = \
timeeventq-test.c \
timeeventq.h timeeventq.c \