summaryrefslogtreecommitdiffstats
path: root/avahi-core/Makefile.am
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2005-07-16 20:14:34 +0000
committerLennart Poettering <lennart@poettering.net>2005-07-16 20:14:34 +0000
commit774b0629a3536eda0b560e092964cf94d6b742aa (patch)
tree7f0fa10f0488c5053c25053a5ab9402054af3fbe /avahi-core/Makefile.am
parentb1e07e8d002b0078a3b56a22979f47bcccf73306 (diff)
* hide some more files
* make sure not to run a time event twice in the same main loop iteration * add new test timeeventq-test git-svn-id: file:///home/lennart/svn/public/avahi/trunk@167 941a03a8-eaeb-0310-b9a0-b1bbd8fe43fe
Diffstat (limited to 'avahi-core/Makefile.am')
-rw-r--r--avahi-core/Makefile.am10
1 files changed, 9 insertions, 1 deletions
diff --git a/avahi-core/Makefile.am b/avahi-core/Makefile.am
index 0c6b1e2..7abc497 100644
--- a/avahi-core/Makefile.am
+++ b/avahi-core/Makefile.am
@@ -44,7 +44,8 @@ noinst_PROGRAMS = \
avahi-test \
conformance-test \
avahi-reflector \
- dns-test
+ dns-test \
+ timeeventq-test
libavahi_core_la_SOURCES = \
timeeventq.c timeeventq.h\
@@ -105,6 +106,13 @@ dns_test_SOURCES = \
dns_test_CFLAGS = $(AM_CFLAGS)
dns_test_LDADD = $(AM_LDADD) $(STATIC_COMMON_LDADD)
+timeeventq_test_SOURCES = \
+ timeeventq-test.c \
+ timeeventq.h timeeventq.c \
+ prioq.h prioq.c
+timeeventq_test_CFLAGS = $(AM_CFLAGS)
+timeeventq_test_LDADD = $(AM_LDADD) $(STATIC_COMMON_LDADD)
+
valgrind: avahi-test
libtool --mode=execute valgrind ./avahi-test