summaryrefslogtreecommitdiffstats
path: root/avahi-core/Makefile.am
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2005-06-06 09:34:19 +0000
committerLennart Poettering <lennart@poettering.net>2005-06-06 09:34:19 +0000
commite877dd63989740389135513745c92b253fefd3fe (patch)
tree9ca0507167d9aa8aa82e41e38ce1cae94562895f /avahi-core/Makefile.am
parentfd84f9ae1c1ccaf7090e0b4f8876948bea040117 (diff)
move dns.[ch] back to avahi-core/
git-svn-id: file:///home/lennart/svn/public/avahi/trunk@104 941a03a8-eaeb-0310-b9a0-b1bbd8fe43fe
Diffstat (limited to 'avahi-core/Makefile.am')
-rw-r--r--avahi-core/Makefile.am18
1 files changed, 14 insertions, 4 deletions
diff --git a/avahi-core/Makefile.am b/avahi-core/Makefile.am
index b692fcc..6920e8c 100644
--- a/avahi-core/Makefile.am
+++ b/avahi-core/Makefile.am
@@ -21,9 +21,11 @@ AM_CFLAGS=-I$(top_srcdir) -D_GNU_SOURCE
# GLIB 2.0
AM_CFLAGS+=$(GLIB20_CFLAGS)
-AM_LDADD=$(GLIB20_LIBS) ../avahi-common/libavahi-common.la
+AM_LDADD=$(GLIB20_LIBS)
-AM_CFLAGS+=-I$(top_srcdir)/avahi-common
+# Import stuff from avahi-common
+AM_CFLAGS+=-I$(top_srcdir)/avahi-common
+AM_LDADD+=../avahi-common/libavahi-common.la
# This cool debug trap works on i386/gcc only
AM_CFLAGS+='-DDEBUG_TRAP=__asm__("int $$3")'
@@ -40,7 +42,8 @@ noinst_PROGRAMS = \
prioq-test \
avahi-test \
conformance-test \
- avahi-reflector
+ avahi-reflector \
+ dns-test
libavahi_core_la_SOURCES = \
timeeventq.c timeeventq.h\
@@ -61,7 +64,8 @@ libavahi_core_la_SOURCES = \
browse-domain.c \
browse-service-type.c \
browse-service.c \
- resolve-service.c
+ resolve-service.c \
+ dns.c dns.h
prioq_test_SOURCES = \
prioq-test.c \
@@ -87,6 +91,12 @@ avahi_reflector_SOURCES = \
avahi_reflector_CFLAGS = $(AM_CFLAGS)
avahi_reflector_LDADD = $(AM_LDADD)
+dns_test_SOURCES = \
+ dns.c dns.h \
+ dns-test.c
+dns_test_CFLAGS = $(AM_CFLAGS)
+dns_test_LDADD = $(AM_LDADD)
+
valgrind: avahi-test
libtool --mode=execute valgrind ./avahi-test