summaryrefslogtreecommitdiffstats
path: root/avahi-core/Makefile.am
diff options
context:
space:
mode:
authorSjoerd Simons <sjoerd@luon.net>2008-06-22 18:27:57 +0200
committerLennart Poettering <lennart@poettering.net>2008-06-24 00:22:39 +0200
commitff96a35f43eceb5ddf031b9730cbcd9b2aa8c16e (patch)
treec5f0472b799de326216a529ee286207da77d722b /avahi-core/Makefile.am
parentbfa5699f5474c7d964ed56046ca0c3561836ff3c (diff)
Make avahi compile on GNU/Hurd. Patch by Samuel Thibault.
Diffstat (limited to 'avahi-core/Makefile.am')
-rw-r--r--avahi-core/Makefile.am11
1 files changed, 7 insertions, 4 deletions
diff --git a/avahi-core/Makefile.am b/avahi-core/Makefile.am
index 8d3b97f..d190c66 100644
--- a/avahi-core/Makefile.am
+++ b/avahi-core/Makefile.am
@@ -1,7 +1,7 @@
# $Id$
#
# This file is part of avahi.
-#
+#
# avahi is free software; you can redistribute it and/or modify it
# under the terms of the GNU Lesser General Public License as
# published by the Free Software Foundation; either version 2 of the
@@ -32,7 +32,7 @@ avahiinclude_HEADERS = \
lookup.h
lib_LTLIBRARIES = \
- libavahi-core.la
+ libavahi-core.la
if ENABLE_TESTS
noinst_PROGRAMS = \
@@ -51,7 +51,7 @@ TESTS = \
dns-spin-test \
dns-test \
hashmap-test
-endif
+endif
libavahi_core_la_SOURCES = \
timeeventq.c timeeventq.h\
@@ -92,9 +92,12 @@ libavahi_core_la_SOURCES += \
iface-linux.c iface-linux.h \
netlink.c netlink.h
else
-if HAVE_PF_ROUTE
+if HAVE_PF_ROUTE
libavahi_core_la_SOURCES += \
iface-pfroute.c iface-pfroute.h
+else
+libavahi_core_la_SOURCES += \
+ iface-none.c
endif
endif