summaryrefslogtreecommitdiffstats
path: root/avahi-core/Makefile.am
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2005-05-17 00:03:50 +0000
committerLennart Poettering <lennart@poettering.net>2005-05-17 00:03:50 +0000
commit28d336020ca1f6dbb88d64cac3ffdd1a67ee3de7 (patch)
tree3562ceea432fa92aed64c3c8b365555165c87318 /avahi-core/Makefile.am
parent7ef880c32da573ba044cde87ae99a98a6038b7d1 (diff)
* split packet scheduler into three seperate parts
* test against Aplle test suit, most tests pass now * suppress auxiliary records by known answers * handle very large records git-svn-id: file:///home/lennart/svn/public/avahi/trunk@74 941a03a8-eaeb-0310-b9a0-b1bbd8fe43fe
Diffstat (limited to 'avahi-core/Makefile.am')
-rw-r--r--avahi-core/Makefile.am14
1 files changed, 11 insertions, 3 deletions
diff --git a/avahi-core/Makefile.am b/avahi-core/Makefile.am
index cd22097..7554d24 100644
--- a/avahi-core/Makefile.am
+++ b/avahi-core/Makefile.am
@@ -35,7 +35,8 @@ noinst_PROGRAMS = \
prioq-test \
strlst-test \
avahi-test \
- alternative-test
+ alternative-test \
+ conformance-test
libavahi_core_la_SOURCES = \
timeeventq.c timeeventq.h\
@@ -49,7 +50,9 @@ libavahi_core_la_SOURCES = \
rr.c rr.h \
dns.c dns.h \
socket.c socket.h \
- psched.c psched.h \
+ response-sched.c response-sched.h \
+ query-sched.c query-sched.h \
+ probe-sched.c probe-sched.h \
announce.c announce.h \
subscribe.c subscribe.h \
strlst.c strlst.h \
@@ -85,7 +88,6 @@ dns_test_LDADD = $(AM_LDADD)
avahi_test_SOURCES = \
avahi-test.c \
$(libavahi_core_la_SOURCES)
-
avahi_test_CFLAGS = $(AM_CFLAGS)
avahi_test_LDADD = $(AM_LDADD)
@@ -95,6 +97,12 @@ alternative_test_SOURCES = \
alternative_test_CFLAGS = $(AM_CFLAGS)
alternative_test_LDADD = $(AM_LDADD)
+conformance_test_SOURCES = \
+ conformance-test.c \
+ $(libavahi_core_la_SOURCES)
+conformance_test_CFLAGS = $(AM_CFLAGS)
+conformance_test_LDADD = $(AM_LDADD)
+
valgrind: avahi-test
libtool --mode=execute valgrind ./avahi-test