summaryrefslogtreecommitdiffstats
path: root/avahi-core/Makefile.am
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2005-05-16 01:01:43 +0000
committerLennart Poettering <lennart@poettering.net>2005-05-16 01:01:43 +0000
commitf5a4db2039532ef93fbb3d98fa048be9d74a83fe (patch)
treeb3db891f27468f13ed2851f3f69e843823780dbc /avahi-core/Makefile.am
parenta3596a5e3ec4937a220e6e60218639e2aba82701 (diff)
* case insensitive name comparisons
* corectly handle RRsets * make addresses unique * return to probe state on conflict * a bunch of fixes detected while testing against the Apple Bonjour Conformance Test * a fix in avahi_record_lexicographical_cmp() regarding TXT records * API for choosing alternative host and service names * remove a bunch of unused crap from cache.c and server.c * flush cache when an interface becomes unavailable git-svn-id: file:///home/lennart/svn/public/avahi/trunk@72 941a03a8-eaeb-0310-b9a0-b1bbd8fe43fe
Diffstat (limited to 'avahi-core/Makefile.am')
-rw-r--r--avahi-core/Makefile.am17
1 files changed, 13 insertions, 4 deletions
diff --git a/avahi-core/Makefile.am b/avahi-core/Makefile.am
index e6708b6..cd22097 100644
--- a/avahi-core/Makefile.am
+++ b/avahi-core/Makefile.am
@@ -27,14 +27,15 @@ AM_LDADD=$(GLIB20_LIBS)
AM_CFLAGS+='-DDEBUG_TRAP=__asm__("int $$3")'
lib_LTLIBRARIES = \
- libavahi-core.la
+ libavahi-core.la
noinst_PROGRAMS = \
dns-test \
domain-test \
prioq-test \
strlst-test \
- avahi-test
+ avahi-test \
+ alternative-test
libavahi_core_la_SOURCES = \
timeeventq.c timeeventq.h\
@@ -82,9 +83,17 @@ dns_test_CFLAGS = $(AM_CFLAGS)
dns_test_LDADD = $(AM_LDADD)
avahi_test_SOURCES = \
- avahi-test.c
+ avahi-test.c \
+ $(libavahi_core_la_SOURCES)
+
avahi_test_CFLAGS = $(AM_CFLAGS)
-avahi_test_LDADD = $(AM_LDADD) libavahi-core.la
+avahi_test_LDADD = $(AM_LDADD)
+
+alternative_test_SOURCES = \
+ alternative-test.c \
+ util.c util.h
+alternative_test_CFLAGS = $(AM_CFLAGS)
+alternative_test_LDADD = $(AM_LDADD)
valgrind: avahi-test
libtool --mode=execute valgrind ./avahi-test