summaryrefslogtreecommitdiffstats
path: root/avahi-daemon/Makefile.am
diff options
context:
space:
mode:
authorTrent Lloyd <lathiat@bur.st>2005-06-05 02:37:27 +0000
committerTrent Lloyd <lathiat@bur.st>2005-06-05 02:37:27 +0000
commit34a736c9ba029dd6bde61c3afba175e206a0a736 (patch)
treef66abc1f9efc3c62f2096c37d719f5db2c961861 /avahi-daemon/Makefile.am
parent64dff8088b43bd2f367f35e18bf02e73c8052dec (diff)
* rename daemon to avahi-daemon
git-svn-id: file:///home/lennart/svn/public/avahi/trunk@101 941a03a8-eaeb-0310-b9a0-b1bbd8fe43fe
Diffstat (limited to 'avahi-daemon/Makefile.am')
-rw-r--r--avahi-daemon/Makefile.am40
1 files changed, 40 insertions, 0 deletions
diff --git a/avahi-daemon/Makefile.am b/avahi-daemon/Makefile.am
new file mode 100644
index 0000000..8bf007d
--- /dev/null
+++ b/avahi-daemon/Makefile.am
@@ -0,0 +1,40 @@
+# $Id: Makefile.am 52 2005-05-06 16:23:30Z lennart $
+#
+# This file is part of avahi.
+#
+# avahi is free software; you can redistribute it and/or modify it
+# under the terms of the GNU Lesser General Public License as
+# published by the Free Software Foundation; either version 2 of the
+# License, or (at your option) any later version.
+#
+# avahi is distributed in the hope that it will be useful, but WITHOUT
+# ANY WARRANTY; without even the implied warranty of MERCHANTABILITY
+# or FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public
+# License for more details.
+#
+# You should have received a copy of the GNU Lesser General Public
+# License along with avahi; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307
+# USA.
+
+AM_CFLAGS=-I$(top_srcdir) -D_GNU_SOURCE
+
+# GLIB 2.0
+AM_CFLAGS+=$(GLIB20_CFLAGS)
+AM_LDADD=$(GLIB20_LIBS)
+
+# DBUS
+AM_CFLAGS+=$(DBUS_CFLAGS)
+AM_LDADD+=$(DBUS_LIBS)
+
+# This cool debug trap works on i386/gcc only
+AM_CFLAGS+='-DDEBUG_TRAP=__asm__("int $$3")'
+
+bin_PROGRAMS = \
+ avahi
+
+avahi_SOURCES = \
+ main.c
+
+avahi_CFLAGS = $(AM_CFLAGS)
+avahi_LDADD = $(AM_LDADD) ../avahi-core/libavahi-core.la ../avahi-common/libavahi-common.la