summaryrefslogtreecommitdiffstats
path: root/avahi-daemon/Makefile.am
diff options
context:
space:
mode:
authorTrent Lloyd <lathiat@bur.st>2005-06-08 18:55:06 +0000
committerTrent Lloyd <lathiat@bur.st>2005-06-08 18:55:06 +0000
commitce170511234a040ea6f418b168beb3a6e51a1f2c (patch)
tree1e2dc7c1998185f77ff841f5e1d17a09fdfa507d /avahi-daemon/Makefile.am
parent1f2b8ac4ae09b15a0a6d1f7633f888654fd271dd (diff)
* Patch by Ross Burton to enable conditional use of dbus (--enable-dbus=no), disables daemon build
* Remove doxygen from EXTRA_DIST as its built by default now git-svn-id: file:///home/lennart/svn/public/avahi/trunk@107 941a03a8-eaeb-0310-b9a0-b1bbd8fe43fe
Diffstat (limited to 'avahi-daemon/Makefile.am')
-rw-r--r--avahi-daemon/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/avahi-daemon/Makefile.am b/avahi-daemon/Makefile.am
index 8bf007d..3a03393 100644
--- a/avahi-daemon/Makefile.am
+++ b/avahi-daemon/Makefile.am
@@ -30,6 +30,7 @@ AM_LDADD+=$(DBUS_LIBS)
# This cool debug trap works on i386/gcc only
AM_CFLAGS+='-DDEBUG_TRAP=__asm__("int $$3")'
+if ENABLE_DBUS
bin_PROGRAMS = \
avahi
@@ -38,3 +39,4 @@ avahi_SOURCES = \
avahi_CFLAGS = $(AM_CFLAGS)
avahi_LDADD = $(AM_LDADD) ../avahi-core/libavahi-core.la ../avahi-common/libavahi-common.la
+endif