summaryrefslogtreecommitdiffstats
path: root/avahi-discover-standalone/Makefile.am
diff options
context:
space:
mode:
authorSebastien Estienne <sebastien.estienne@gmail.com>2005-08-04 00:57:03 +0000
committerSebastien Estienne <sebastien.estienne@gmail.com>2005-08-04 00:57:03 +0000
commit3bf52c1e00fd8cf4850329adb4f76c3c2649df79 (patch)
tree7055068f07e80a8777f4ac36b9dea7777ccca606 /avahi-discover-standalone/Makefile.am
parentcc0a4994f07b61952a77549fffa1711014f936be (diff)
* renamed avahi-discover to avahi-discover-standalone
* install python avahi-discover * added missing file acinclude.m4 git-svn-id: file:///home/lennart/svn/public/avahi/trunk@225 941a03a8-eaeb-0310-b9a0-b1bbd8fe43fe
Diffstat (limited to 'avahi-discover-standalone/Makefile.am')
-rw-r--r--avahi-discover-standalone/Makefile.am46
1 files changed, 46 insertions, 0 deletions
diff --git a/avahi-discover-standalone/Makefile.am b/avahi-discover-standalone/Makefile.am
new file mode 100644
index 0000000..2d3ddaf
--- /dev/null
+++ b/avahi-discover-standalone/Makefile.am
@@ -0,0 +1,46 @@
+# $Id$
+#
+# This file is part of avahi.
+#
+# avahi is free software; you can redistribute it and/or modify it
+# under the terms of the GNU Lesser General Public License as
+# published by the Free Software Foundation; either version 2 of the
+# License, or (at your option) any later version.
+#
+# avahi is distributed in the hope that it will be useful, but WITHOUT
+# ANY WARRANTY; without even the implied warranty of MERCHANTABILITY
+# or FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public
+# License for more details.
+#
+# You should have received a copy of the GNU Lesser General Public
+# License along with avahi; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307
+# USA.
+
+AM_CFLAGS=-I$(top_srcdir) \
+ -DAVAHI_INTERFACES_DIR=\"$(interfacesdir)\"
+
+AM_CFLAGS+=$(GLIB20_CFLAGS) $(GTK20_CFLAGS) $(GLADE20_CFLAGS)
+AM_LDADD=$(GLIB20_LIBS) $(GTK20_LIBS) $(GLADE20_LIBS)
+
+# This cool debug trap works on i386/gcc only
+AM_CFLAGS+='-DDEBUG_TRAP=__asm__("int $$3")'
+
+if ENABLE_GTK
+bin_PROGRAMS = \
+ avahi-discover-standalone
+
+avahi_discover_standalone_SOURCES = \
+ main.c
+
+avahi_discover_standalone_CFLAGS = $(AM_CFLAGS)
+avahi_discover_standalone_LDADD = $(AM_LDADD) ../avahi-core/libavahi-core.la ../avahi-common/libavahi-common.la
+
+interfaces = \
+ avahi-discover.glade
+
+interfaces_DATA = $(interfaces)
+
+EXTRA_DIST = \
+ $(interfaces)
+endif