summaryrefslogtreecommitdiffstats
path: root/avahi-discover/Makefile.am
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2005-05-23 16:39:01 +0000
committerLennart Poettering <lennart@poettering.net>2005-05-23 16:39:01 +0000
commitf1b541eb614861312f917dab1bf75ad8267e321a (patch)
tree70c2dda7ba88b7545a23cde1481740811b6d6aa1 /avahi-discover/Makefile.am
parente1f934bbe96fd8e7f3f5212b783c0d3a434d4789 (diff)
* add new tool avahi-discover
git-svn-id: file:///home/lennart/svn/public/avahi/trunk@91 941a03a8-eaeb-0310-b9a0-b1bbd8fe43fe
Diffstat (limited to 'avahi-discover/Makefile.am')
-rw-r--r--avahi-discover/Makefile.am35
1 files changed, 35 insertions, 0 deletions
diff --git a/avahi-discover/Makefile.am b/avahi-discover/Makefile.am
new file mode 100644
index 0000000..9eca34d
--- /dev/null
+++ b/avahi-discover/Makefile.am
@@ -0,0 +1,35 @@
+# $Id$
+#
+# This file is part of avahi.
+#
+# avahi is free software; you can redistribute it and/or modify it
+# under the terms of the GNU Lesser General Public License as
+# published by the Free Software Foundation; either version 2 of the
+# License, or (at your option) any later version.
+#
+# avahi is distributed in the hope that it will be useful, but WITHOUT
+# ANY WARRANTY; without even the implied warranty of MERCHANTABILITY
+# or FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public
+# License for more details.
+#
+# You should have received a copy of the GNU Lesser General Public
+# License along with avahi; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307
+# USA.
+
+AM_CFLAGS=-I$(top_srcdir) -D_GNU_SOURCE
+
+AM_CFLAGS+=$(GLIB20_CFLAGS) $(GTK20_CFLAGS) $(GLADE20_CFLAGS)
+AM_LDADD=$(GLIB20_LIBS) $(GTK20_LIBS) $(GLADE20_LIBS)
+
+# This cool debug trap works on i386/gcc only
+AM_CFLAGS+='-DDEBUG_TRAP=__asm__("int $$3")'
+
+bin_PROGRAMS = \
+ avahi-discover
+
+avahi_discover_SOURCES = \
+ main.c
+
+avahi_discover_CFLAGS = $(AM_CFLAGS)
+avahi_discover_LDADD = $(AM_LDADD) ../avahi-core/libavahi-core.la