summaryrefslogtreecommitdiffstats
path: root/avahi-dnsconfd/Makefile.am
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2005-06-24 01:00:13 +0000
committerLennart Poettering <lennart@poettering.net>2005-06-24 01:00:13 +0000
commit9f9f4f6ea2405edc642d322c19f6f13e31920046 (patch)
tree2a4a3a8ecbe0f942a140a98b4f1621d183575297 /avahi-dnsconfd/Makefile.am
parent697d33e34648286fd42ff6086087e0111726f749 (diff)
* update todo list
* add avvahi-dnsconfd * implement AvahiDNSServerBrowser * Update special browse/register RRs to match current RFC * add support to avahi-daemon to publish name server information * add support to avahi-daemon to publish /etc/resolv.conf DNS server information * add new simple protocol command: "BROWSE-DNS-SERVERS" * cleanup final configure message git-svn-id: file:///home/lennart/svn/public/avahi/trunk@143 941a03a8-eaeb-0310-b9a0-b1bbd8fe43fe
Diffstat (limited to 'avahi-dnsconfd/Makefile.am')
-rw-r--r--avahi-dnsconfd/Makefile.am51
1 files changed, 51 insertions, 0 deletions
diff --git a/avahi-dnsconfd/Makefile.am b/avahi-dnsconfd/Makefile.am
new file mode 100644
index 0000000..8a0787a
--- /dev/null
+++ b/avahi-dnsconfd/Makefile.am
@@ -0,0 +1,51 @@
+# $Id$
+#
+# This file is part of avahi.
+#
+# avahi is free software; you can redistribute it and/or modify it
+# under the terms of the GNU Lesser General Public License as
+# published by the Free Software Foundation; either version 2 of the
+# License, or (at your option) any later version.
+#
+# avahi is distributed in the hope that it will be useful, but WITHOUT
+# ANY WARRANTY; without even the implied warranty of MERCHANTABILITY
+# or FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public
+# License for more details.
+#
+# You should have received a copy of the GNU Lesser General Public
+# License along with avahi; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307
+# USA.
+
+pkgsysconfdir=$(sysconfdir)/avahi
+
+AM_CFLAGS= \
+ -I$(top_srcdir) \
+ -D_GNU_SOURCE \
+ -DAVAHI_DNSCONF_SCRIPT=\"$(pkgsysconfdir)/dnsconf.action\" \
+ -DAVAHI_SOCKET=\"$(localstatedir)/run/avahi/socket\" \
+ -DAVAHI_RUNTIME_DIR=\"$(localstatedir)/run\"
+
+# GLIB 2.0
+AM_CFLAGS+=$(GLIB20_CFLAGS)
+AM_LDADD=$(GLIB20_LIBS)
+
+# libdaemon
+AM_CFLAGS+=$(LIBDAEMON_CFLAGS)
+AM_LDADD+=$(LIBDAEMON_LIBS)
+
+# This cool debug trap works on i386/gcc only
+AM_CFLAGS+='-DDEBUG_TRAP=__asm__("int $$3")'
+
+bin_PROGRAMS = \
+ avahi-dnsconfd
+
+avahi_dnsconfd_SOURCES = \
+ main.c main.h
+
+avahi_dnsconfd_CFLAGS = $(AM_CFLAGS)
+avahi_dnsconfd_LDADD = $(AM_LDADD) ../avahi-common/libavahi-common.la
+
+pkgsysconf_DATA=dnsconf.action
+
+EXTRA_DIST=dnsconf.action