summaryrefslogtreecommitdiffstats
path: root/avahi-glib/Makefile.am
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2005-08-13 21:25:09 +0000
committerLennart Poettering <lennart@poettering.net>2005-08-13 21:25:09 +0000
commit4f0a5e7572a4257894b4bfede42c26d65152609e (patch)
tree21e3d5ee20716739590e5931859a4c2052161395 /avahi-glib/Makefile.am
parentd6d7d3769441b73ffb5b7af34fef823b41e66312 (diff)
* strip glib from avahi-core
* implement glib memory allocator * add new documentation file MALLOC * initialize pseudo-RNG from /dev/urandom in avahi-daemon * remove some gcc 4.0 warnings * beef up watch system with real timeouts * move GCC __attribute__ macros into its own header avahi-common/gccmacro.h * make use of GCC's sentinel attribute where it make sense * add malloc() implementations that abort on OOM and enable them by default git-svn-id: file:///home/lennart/svn/public/avahi/trunk@308 941a03a8-eaeb-0310-b9a0-b1bbd8fe43fe
Diffstat (limited to 'avahi-glib/Makefile.am')
-rw-r--r--avahi-glib/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/avahi-glib/Makefile.am b/avahi-glib/Makefile.am
index 6cfc46e..dd5a14f 100644
--- a/avahi-glib/Makefile.am
+++ b/avahi-glib/Makefile.am
@@ -33,6 +33,7 @@ avahiincludedir=$(includedir)/avahi-glib
avahiinclude_HEADERS = \
glib-watch.h
+ glib-malloc.h
lib_LTLIBRARIES = \
libavahi-glib.la
@@ -41,7 +42,8 @@ noinst_PROGRAMS = \
glib-watch-test
libavahi_glib_la_SOURCES = \
- glib-watch.c glib-watch.h
+ glib-watch.c glib-watch.h \
+ glib-malloc.h glib-malloc.c
libavahi_glib_la_CFLAGS = $(AM_CFLAGS)
libavahi_glib_la_LIBADD = $(AM_LDADD) $(COMMON_LDADD)