summaryrefslogtreecommitdiffstats
path: root/avahi-glib/Makefile.am
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2005-08-12 19:09:50 +0000
committerLennart Poettering <lennart@poettering.net>2005-08-12 19:09:50 +0000
commit5d047523c87ba11aad8c384f7ffde25b4dd746ed (patch)
treeb160aa74a0c9e77db3bc9b864f503771adaa6758 /avahi-glib/Makefile.am
parentf8c479234af6b676027df4fb6b38ce8e22949049 (diff)
implement new main loop abstraction layer
git-svn-id: file:///home/lennart/svn/public/avahi/trunk@305 941a03a8-eaeb-0310-b9a0-b1bbd8fe43fe
Diffstat (limited to 'avahi-glib/Makefile.am')
-rw-r--r--avahi-glib/Makefile.am57
1 files changed, 57 insertions, 0 deletions
diff --git a/avahi-glib/Makefile.am b/avahi-glib/Makefile.am
new file mode 100644
index 0000000..6cfc46e
--- /dev/null
+++ b/avahi-glib/Makefile.am
@@ -0,0 +1,57 @@
+# $Id$
+#
+# This file is part of avahi.
+#
+# avahi is free software; you can redistribute it and/or modify it
+# under the terms of the GNU Lesser General Public License as
+# published by the Free Software Foundation; either version 2 of the
+# License, or (at your option) any later version.
+#
+# avahi is distributed in the hope that it will be useful, but WITHOUT
+# ANY WARRANTY; without even the implied warranty of MERCHANTABILITY
+# or FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public
+# License for more details.
+#
+# You should have received a copy of the GNU Lesser General Public
+# License along with avahi; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307
+# USA.
+
+AM_CFLAGS=-I$(top_srcdir)
+
+# GLIB 2.0
+AM_CFLAGS+=$(GLIB20_CFLAGS)
+AM_LDADD=$(GLIB20_LIBS)
+
+# Import stuff from avahi-common
+COMMON_LDADD=../avahi-common/libavahi-common.la
+
+# This cool debug trap works on i386/gcc only
+AM_CFLAGS+='-DDEBUG_TRAP=__asm__("int $$3")'
+
+avahiincludedir=$(includedir)/avahi-glib
+
+avahiinclude_HEADERS = \
+ glib-watch.h
+
+lib_LTLIBRARIES = \
+ libavahi-glib.la
+
+noinst_PROGRAMS = \
+ glib-watch-test
+
+libavahi_glib_la_SOURCES = \
+ glib-watch.c glib-watch.h
+libavahi_glib_la_CFLAGS = $(AM_CFLAGS)
+libavahi_glib_la_LIBADD = $(AM_LDADD) $(COMMON_LDADD)
+
+glib_watch_test_SOURCES = \
+ glib-watch.c glib-watch.h \
+ glib-watch-test.c
+glib_watch_test_CFLAGS = $(AM_CFLAGS)
+glib_watch_test_LDADD = $(AM_LDADD) $(COMMON_LDADD)
+
+
+
+
+