summaryrefslogtreecommitdiffstats
path: root/avahi-python/avahi/Makefile.am
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2006-08-06 11:54:31 +0000
committerLennart Poettering <lennart@poettering.net>2006-08-06 11:54:31 +0000
commitb7d566fc3ec60c0fbbca22af273bc67fdc1372fa (patch)
tree7e39f656c03db8daaee14bcd63e3722f2354ea45 /avahi-python/avahi/Makefile.am
parentd66af491a574de4d5421c995bec5357fc1c04128 (diff)
Allow storing the service type database as Solaris DBM file, alternatively to gdbm. The latter is still recommended. (Patch from Padraig O'Briain)
git-svn-id: file:///home/lennart/svn/public/avahi/trunk@1245 941a03a8-eaeb-0310-b9a0-b1bbd8fe43fe
Diffstat (limited to 'avahi-python/avahi/Makefile.am')
-rw-r--r--avahi-python/avahi/Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/avahi-python/avahi/Makefile.am b/avahi-python/avahi/Makefile.am
index b1ebe22..5673d5e 100644
--- a/avahi-python/avahi/Makefile.am
+++ b/avahi-python/avahi/Makefile.am
@@ -25,10 +25,27 @@ avahidir = $(pythondir)/avahi
avahi_SCRIPTS = ServiceTypeDatabase.py
+if HAVE_GDBM
ServiceTypeDatabase.py: ServiceTypeDatabase.py.in
sed -e 's,@PYTHON\@,$(PYTHON),g' \
+ -e 's,@DBM\@,gdbm,g' \
+ -e 's,@FIRST_KEY\@,key = self.db.firstkey(),g' \
+ -e 's,@CHECK_KEY\@,while key is not None:,g' \
+ -e 's,@NEXT_KEY\@,key = self.db.nextkey(),g' \
-e 's,@pkgdatadir\@,$(pkgdatadir),g' $< > $@
chmod +x $@
+endif
+
+if HAVE_DBM
+ServiceTypeDatabase.py: ServiceTypeDatabase.py.in
+ sed -e 's,@PYTHON\@,$(PYTHON),g' \
+ -e 's,@DBM\@,dbm,g' \
+ -e 's,@FIRST_KEY\@,keys = self.db.keys(),g' \
+ -e 's,@CHECK_KEY\@,for key in keys:,g' \
+ -e 's,@NEXT_KEY\@,,g' \
+ -e 's,@pkgdatadir\@,$(pkgdatadir),g' $< > $@
+ chmod +x $@
+endif
if HAVE_PYGTK
if HAVE_PYTHON_DBUS