summaryrefslogtreecommitdiffstats
path: root/avahi-python/avahi/Makefile.am
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2005-11-15 00:39:45 +0000
committerLennart Poettering <lennart@poettering.net>2005-11-15 00:39:45 +0000
commitced0d86acf70f435ffdadb794db891be63a5b82a (patch)
tree2cad1e6412804127de11fc7b2338b155ad01925e /avahi-python/avahi/Makefile.am
parent2d48326e6731cb9266119cd531daac0bbf683f44 (diff)
move python tools from avahi-utils to avahi-python
git-svn-id: file:///home/lennart/svn/public/avahi/trunk@969 941a03a8-eaeb-0310-b9a0-b1bbd8fe43fe
Diffstat (limited to 'avahi-python/avahi/Makefile.am')
-rw-r--r--avahi-python/avahi/Makefile.am44
1 files changed, 44 insertions, 0 deletions
diff --git a/avahi-python/avahi/Makefile.am b/avahi-python/avahi/Makefile.am
new file mode 100644
index 0000000..b1ebe22
--- /dev/null
+++ b/avahi-python/avahi/Makefile.am
@@ -0,0 +1,44 @@
+# $Id$
+
+# This file is part of avahi.
+#
+# avahi is free software; you can redistribute it and/or modify it
+# under the terms of the GNU Lesser General Public License as
+# published by the Free Software Foundation; either version 2 of the
+# License, or (at your option) any later version.
+#
+# avahi is distributed in the hope that it will be useful, but WITHOUT
+# ANY WARRANTY; without even the implied warranty of MERCHANTABILITY
+# or FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public
+# License for more details.
+#
+# You should have received a copy of the GNU Lesser General Public
+# License along with avahi; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307
+# USA.
+
+EXTRA_DIST = __init__.py SimpleGladeApp.py ServiceTypeDatabase.py.in
+
+if HAVE_PYTHON
+
+avahidir = $(pythondir)/avahi
+
+avahi_SCRIPTS = ServiceTypeDatabase.py
+
+ServiceTypeDatabase.py: ServiceTypeDatabase.py.in
+ sed -e 's,@PYTHON\@,$(PYTHON),g' \
+ -e 's,@pkgdatadir\@,$(pkgdatadir),g' $< > $@
+ chmod +x $@
+
+if HAVE_PYGTK
+if HAVE_PYTHON_DBUS
+
+avahi_PYTHON = __init__.py SimpleGladeApp.py
+
+endif
+endif
+endif
+
+CLEANFILES=*.pyc *.pyo ServiceTypeDatabase.py
+
+