summaryrefslogtreecommitdiffstats
path: root/avahi-sharp/Makefile.am
diff options
context:
space:
mode:
authorJames Willcox <snopr@snorp.net>2005-09-09 18:41:51 +0000
committerJames Willcox <snopr@snorp.net>2005-09-09 18:41:51 +0000
commita21074b9ea4b11b74d114e2669248f979caf0d3a (patch)
tree0a51486c45514bdecd500a012f59039c53ecba3d /avahi-sharp/Makefile.am
parent8263f6594082e5c892a9425707413a386733fef4 (diff)
integrate mono bindings into the build
git-svn-id: file:///home/lennart/svn/public/avahi/trunk@540 941a03a8-eaeb-0310-b9a0-b1bbd8fe43fe
Diffstat (limited to 'avahi-sharp/Makefile.am')
-rw-r--r--avahi-sharp/Makefile.am18
1 files changed, 13 insertions, 5 deletions
diff --git a/avahi-sharp/Makefile.am b/avahi-sharp/Makefile.am
index a82f4e6..ffee4cd 100644
--- a/avahi-sharp/Makefile.am
+++ b/avahi-sharp/Makefile.am
@@ -1,6 +1,9 @@
-all: avahi-sharp.dll
+ASSEMBLY = avahi-sharp.dll
+
+CLEANFILES = $(ASSEMBLY) $(ASSEMBLY).mdb
+EXTRA_DIST = $(AVAHISOURCES) avahi.snk
AVAHISOURCES = \
$(srcdir)/AddressResolver.cs \
@@ -12,9 +15,14 @@ AVAHISOURCES = \
$(srcdir)/ServiceBrowser.cs \
$(srcdir)/ServiceResolver.cs \
$(srcdir)/ServiceTypeBrowser.cs \
- Utility.cs
+ $(srcdir)/Utility.cs
+
+$(ASSEMBLY): $(AVAHISOURCES)
+ mcs -keyfile:$(srcdir)/avahi.snk -target:library -o $@ -debug $(AVAHISOURCES) -r:Mono.Posix
-avahi-sharp.dll: $(AVAHISOURCES)
- mcs -target:library -o $@ -debug $(AVAHISOURCES) -r:Mono.Posix
+if HAVE_MONO
+all: $(ASSEMBLY)
-CLEANFILES = avahi-sharp.dll avahi-sharp.dll.mdb
+install-data-hook:
+ $(GACUTIL) /i $(ASSEMBLY) /package avahi-sharp /gacdir $(libdir) /root $(DESTDIR)$(libdir)
+endif