summaryrefslogtreecommitdiffstats
path: root/avahi-ui-sharp/Makefile.am
diff options
context:
space:
mode:
authorJames Willcox <snopr@snorp.net>2007-04-19 23:12:35 +0000
committerJames Willcox <snopr@snorp.net>2007-04-19 23:12:35 +0000
commitbe7ce5a2f7f46e48c391d9b9c7501e4e138fc8c5 (patch)
tree1aa6d6859ee2c35e3c8d15baede61b5cd2592dc6 /avahi-ui-sharp/Makefile.am
parent3025a26988fe2de9d14867056c945e20f490ec1e (diff)
add a makefile rule for zssh.exe, and add a .pc file for avahi-ui-sharp
git-svn-id: file:///home/lennart/svn/public/avahi/trunk@1445 941a03a8-eaeb-0310-b9a0-b1bbd8fe43fe
Diffstat (limited to 'avahi-ui-sharp/Makefile.am')
-rw-r--r--avahi-ui-sharp/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/avahi-ui-sharp/Makefile.am b/avahi-ui-sharp/Makefile.am
index b7f020e..ab58dd2 100644
--- a/avahi-ui-sharp/Makefile.am
+++ b/avahi-ui-sharp/Makefile.am
@@ -37,9 +37,12 @@ $(ASSEMBLY): $(AVAHISOURCES)
$(ASSEMBLY).config: $(ASSEMBLY).config.in
$(srcdir)/gencfg.sh $(top_builddir)/avahi-common/libavahi-common.la < $< > $@
+zssh.exe: zssh.cs
+ mcs -out:$@ zssh.cs -r:./avahi-ui-sharp.dll -pkg:gtk-sharp-2.0 -r:Mono.Posix
+
if HAVE_MONO
if HAVE_DBUS
-all: $(ASSEMBLY) $(ASSEMBLY).config
+all: $(ASSEMBLY) $(ASSEMBLY).config zssh.exe
if HAVE_MONODOC
update-docs: $(ASSEMBLY)