summaryrefslogtreecommitdiffstats
path: root/avahi-utils/avahi/Makefile.am
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2005-08-27 17:12:48 +0000
committerLennart Poettering <lennart@poettering.net>2005-08-27 17:12:48 +0000
commit3c7af5cffa21cf302b357c6ab722cdb0615e1950 (patch)
tree065b692530f07e6db0d3372593bd1d83427bf238 /avahi-utils/avahi/Makefile.am
parente7e6788a9596c781528980fca066f57d4afc3adb (diff)
* add new object ServiceTypeDatabase to avahi module for python
git-svn-id: file:///home/lennart/svn/public/avahi/trunk@456 941a03a8-eaeb-0310-b9a0-b1bbd8fe43fe
Diffstat (limited to 'avahi-utils/avahi/Makefile.am')
-rw-r--r--avahi-utils/avahi/Makefile.am17
1 files changed, 13 insertions, 4 deletions
diff --git a/avahi-utils/avahi/Makefile.am b/avahi-utils/avahi/Makefile.am
index 68c7147..c5a4be8 100644
--- a/avahi-utils/avahi/Makefile.am
+++ b/avahi-utils/avahi/Makefile.am
@@ -17,13 +17,22 @@
# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307
# USA.
+EXTRA_DIST = __init__.py SimpleGladeApp.py ServiceTypeDatabase.py.in
+
if HAVE_PYTHON
avahidir = $(pythondir)/avahi
-avahi_PYTHON = __init__.py SimpleGladeApp.py
+avahi_PYTHON = __init__.py SimpleGladeApp.py ServiceTypeDatabase.py
+
+BUILT_SOURCES = ServiceTypeDatabase.py
+
+ServiceTypeDatabase.py: ServiceTypeDatabase.py.in
+ sed -e 's,@PYTHON\@,$(PYTHON),g' \
+ -e 's,@pkgdatadir\@,$(pkgdatadir),g' $< > $@
+ chmod +x $@
+
+CLEANFILES=*.pyc *.pyo ServiceTypeDatabase.py
+
endif
-EXTRA_DIST = __init__.py SimpleGladeApp.py
-clean-local:
- rm -rf *.pyc *.pyo