summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2005-10-22 21:23:02 +0000
committerLennart Poettering <lennart@poettering.net>2005-10-22 21:23:02 +0000
commit2a2ee0be70b99239f2cf99ea5b663eda965599f8 (patch)
tree4ac2d3edc774099855cd58b6d83c2d3e2c963ae4 /configure.ac
parent80ffb739edcbcdc2a22bfed71b7913213392f6ff (diff)
Add init script support for fedora from Alexander Larsson
git-svn-id: file:///home/lennart/svn/public/avahi/trunk@838 941a03a8-eaeb-0310-b9a0-b1bbd8fe43fe
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 315e191..ecc1120 100644
--- a/configure.ac
+++ b/configure.ac
@@ -121,6 +121,7 @@ if test "z$with_distro" = "z"; then
AC_CHECK_FILE(/etc/gentoo-release,with_distro="gentoo")
AC_CHECK_FILE(/etc/arch-release,with_distro="archlinux")
AC_CHECK_FILE(/etc/debian_version,with_distro="debian")
+ AC_CHECK_FILE(/etc/redhat-release,with_distro="fedora")
fi
with_distro=`echo ${with_distro} | tr '[[:upper:]]' '[[:lower:]]' `
@@ -129,7 +130,7 @@ if test "z$with_distro" = "z"; then
exit 1
else
case $with_distro in
- debian|gentoo|archlinux|suse|none)
+ debian|gentoo|archlinux|suse|fedora|none)
;;
*)
AC_MSG_ERROR([Your distribution (${with_distro}) is not yet supported, init scripts and dbus configuration will not be installed! (patches welcome), you can specify --with-distro=none to skip this check])
@@ -141,6 +142,7 @@ AM_CONDITIONAL(TARGET_SUSE, test x"$with_distro" = xsuse)
AM_CONDITIONAL(TARGET_GENTOO, test x"$with_distro" = xgentoo)
AM_CONDITIONAL(TARGET_DEBIAN, test x"$with_distro" = xdebian)
AM_CONDITIONAL(TARGET_ARCHLINUX, test x"$with_distro" = xarchlinux)
+AM_CONDITIONAL(TARGET_FEDORA, test x"$with_distro" = xfedora)
test_gcc_flag() {
AC_LANG_CONFTEST([int main() {}])
@@ -657,6 +659,7 @@ initscript/debian/Makefile
initscript/gentoo/Makefile
initscript/archlinux/Makefile
initscript/suse/Makefile
+initscript/fedora/Makefile
avahi-dnsconfd/Makefile
avahi-utils/Makefile
avahi-utils/avahi/Makefile