summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2006-08-30 16:07:26 +0000
committerLennart Poettering <lennart@poettering.net>2006-08-30 16:07:26 +0000
commit60d86f779725e78ae3d295380f15208859cc06eb (patch)
tree10bd22f59350ca387b9f7bac28817e7c776caba4 /configure.ac
parentc91361ef06f6b94996a78b4c20345c76384b2440 (diff)
add initial version of a RFC3927/IPv4LL implementation
git-svn-id: file:///home/lennart/svn/public/avahi/trunk@1286 941a03a8-eaeb-0310-b9a0-b1bbd8fe43fe
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 6b21c30..8c2b1b5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -660,6 +660,20 @@ fi
AM_CONDITIONAL(HAVE_MONODOC, test "x$HAVE_MONODOC" = "xyes")
#
+# Build autoipd?
+#
+AC_ARG_ENABLE(autoipd,
+ AS_HELP_STRING([--disable-autoipd],[Disable building of avahi-autoipd]),
+ [case "${enableval}" in
+ yes) ENABLE_AUTOIPD=yes ;;
+ no) ENABLE_AUTOIPD=no ;;
+ *) AC_MSG_ERROR(bad value ${enableval} for --disable-autoipd) ;;
+ esac],
+ [ENABLE_AUTOIPD=yes])
+
+AM_CONDITIONAL(ENABLE_AUTOIPD, test "x$ENABLE_AUTOIPD" = "xyes")
+
+#
# Defining Avahi User and Group.
#
AC_ARG_WITH(avahi_user, AS_HELP_STRING([--with-avahi-user=<user>],[User for running the Avahi daemon (avahi)]))
@@ -844,6 +858,7 @@ avahi-sharp/Makefile
avahi-compat-libdns_sd/Makefile
avahi-compat-howl/Makefile
avahi-compat-howl/samples/Makefile
+avahi-autoipd/Makefile
])
AC_OUTPUT
@@ -923,4 +938,5 @@ echo "\
Building avahi-compat-howl: ${ENABLE_COMPAT_HOWL}
Building tests: ${ENABLE_TESTS}
Building avahi-core documentation: ${ENABLE_CORE_DOCS}
+ Building avahi-autoipd: ${ENABLE_AUTOIPD}
"