summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2007-04-15 00:34:30 +0000
committerLennart Poettering <lennart@poettering.net>2007-04-15 00:34:30 +0000
commit6bebc22419959153a45c7640fd7c263d448bc948 (patch)
treeebd227dc02822e2be182ab1c156a531a23bae88c /configure.ac
parent2635b54ef09173bbf72072436fad7d1e1fca3bc9 (diff)
Add inotify support for /ect/avahi/services and /etc/avahi/hosts. Based on a patch from "behanw". (Closes #95, #33)
git-svn-id: file:///home/lennart/svn/public/avahi/trunk@1426 941a03a8-eaeb-0310-b9a0-b1bbd8fe43fe
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 660f138..9ca1f89 100644
--- a/configure.ac
+++ b/configure.ac
@@ -296,6 +296,16 @@ if test "x$HAVE_DLOPEN" = "xyes" ; then
fi
AM_CONDITIONAL(HAVE_DLOPEN, test "x$HAVE_DLOPEN" = "xyes")
+have_inotify=no
+AC_CHECK_HEADERS([linux/inotify.h], [have_inotify=yes])
+AC_CHECK_HEADERS([sys/inotify.h], [have_inotify=yes])
+
+AM_CONDITIONAL(HAVE_INOTIFY, test "x$have_inotify" = "xyes")
+
+if test "x$have_inotify" = "xyes" ; then
+ AC_DEFINE([HAVE_INOTIFY], 1, [Enable Linux inotify() usage])
+fi
+
# Check for pkg-config manually first, as if its not installed the
# PKG_PROG_PKG_CONFIG macro won't be defined.
AC_CHECK_PROG(have_pkg_config, pkg-config, yes, no)
@@ -948,6 +958,7 @@ echo "
User for avahi-autoipd: ${AVAHI_AUTOIPD_USER}
Group for avahi-autoipd: ${AVAHI_AUTOIPD_GROUP}
Enable chroot(): ${enable_chroot}
+ Enable Linux inotify: ${have_inotify}
"
BUILD_DAEMON="no (You need libdaemon and expat!)"