summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2005-10-12 14:46:28 +0000
committerLennart Poettering <lennart@poettering.net>2005-10-12 14:46:28 +0000
commit9ca377e8bc8ef73714180143c24223016acbc845 (patch)
treebd43810dfc2a289eff578cac70bd09da6917572d /configure.ac
parentc283115cb4ae82f332a79bc90696335b82493b8c (diff)
add a real check for linux/netlink.h
git-svn-id: file:///home/lennart/svn/public/avahi/trunk@739 941a03a8-eaeb-0310-b9a0-b1bbd8fe43fe
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 9 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 8db8c53..ba369a1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -74,7 +74,6 @@ case "$host" in
;;
*-linux*)
AC_DEFINE([LINUX],[],[ Support for GNU/Linux])
- AC_DEFINE([HAVE_NETLINK],[],[ Support for netlink.h])
avahi_platform=linux
;;
*-freebsd* | *-kfreebsd*-gnu)
@@ -87,7 +86,15 @@ case "$host" in
;;
esac
-AM_CONDITIONAL(HAVE_NETLINK, [ test x"$avahi_platform" = xlinux ])
+AC_CHECK_HEADER(linux/netlink.h,
+HAVE_NETLINK=yes
+AC_DEFINE([HAVE_NETLINK],[],[Support for Linux netlink])
+, [], [
+#include <sys/socket.h>
+#include <asm/types.h>
+])
+
+AM_CONDITIONAL(HAVE_NETLINK, [ test x"$HAVE_NETLINK" = xyes ])
#
# Detecting the linux distribution for specific things like init scripts.