summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorTrent Lloyd <lathiat@bur.st>2005-10-19 21:55:41 +0000
committerTrent Lloyd <lathiat@bur.st>2005-10-19 21:55:41 +0000
commita26b065238debb81e25106b573addb323e529bce (patch)
tree593087f819650bddf69eaad1dac77bb3d3dfa278 /configure.ac
parent7b0eb2d40a258c84cc2cd77bbca2e91c83b49331 (diff)
* Move some of the man page checks around to catch more situations
* Fix the man dir harder git-svn-id: file:///home/lennart/svn/public/avahi/trunk@828 941a03a8-eaeb-0310-b9a0-b1bbd8fe43fe
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 8 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index bf8f316..17f2f94 100644
--- a/configure.ac
+++ b/configure.ac
@@ -584,15 +584,15 @@ if test x$manpages = xyes ; then
if test x$xmltoman = xyes ; then
AC_CHECK_PROG(have_xmltoman, xmltoman, yes, no)
-
- if test x$have_xmltoman = xno ; then
- if ! test -e man/avahi-daemon.8 ; then
- AC_MSG_ERROR([*** xmltoman was not found, it is required to build the manpages and they have not been pre-built])
- exit 1
- fi
- AC_MSG_WARN([*** Not rebuilding man pages as xmltoman is not found ***])
- xmltoman=no
+ fi
+
+ if test x$have_xmltoman = xno -o x$xmltoman = xno; then
+ if ! test -e man/avahi-daemon.8 ; then
+ AC_MSG_ERROR([*** xmltoman was not found or was disabled, it is required to build the manpages as they have not been pre-built, install xmltoman, pass --disable-manpages or dont pass --disable-xmltoman])
+ exit 1
fi
+ AC_MSG_WARN([*** Not rebuilding man pages as xmltoman is not found ***])
+ xmltoman=no
fi
fi
AM_CONDITIONAL([USE_XMLTOMAN], [test "x$xmltoman" = xyes])